Background compilation renders IntelliJ useless, please help!

I put a Rebuild Project into background mode just after starting it, but it seemed to cripple it. The child process was still running, but nothing appeared in the Messages window and the child process was using 0% CPU. Stopping the build didn't kill the child process and trying to start another build didn't do anything (all the Build menu items literally don't do anything). I tried exiting IntelliJ, but I couldn't, presumably because of the child process, which was still using 0% CPU. I killed the child process from task manager and after a few random windows popping up, I was able to exit IntelliJ cleanly.

After restarting IntelliJ, I tried to do another rebuild and the same thing happened - the build appeared to start, but the child process was using 0% CPU and I got no build output. I tried killing IntelliJ uncleanly and after a restart, it was no different. I've also tried deleting the output directory for the classes. No change.

Our project usually takes 4-5 minutes to compile, but at present, the compiler child process doesn't appear to be doing anything.

I'm now stuck as I can't compile anything! Help!

1 comment
Comment actions Permalink

Maybe there was a rogue process that I didn't spot, but restarting my machine cured the problem. I can now compile.

I still think it should be fixed though!

0

Please sign in to leave a comment.