4 comments
Comment actions Permalink

On JDK 6 the debugger API allows it - and NetBeans is
already using it:
http://www.netbeans.org/issues/show_bug.cgi?id=41113
I have always been missing this feature. How about
adding it for Demetra?
BTW it's IDEABKL-510


Demetra is likely to be released before jdk6, so it is not possible to include features that rely on new version of the jdk.

0
Comment actions Permalink

Hm, I don't really understand.
It's not that Idea needs to run on JDK 6.

If personally I choose to run my own application on JDK 6, Idea could make use of the additional APIs that come with the debugger, couldn't it?

Or are you afraid that the API might still change? The jdk bug was fixed in b19, nor we are somewhere around b95, so I really doubt there is any risk of a change here.

0
Comment actions Permalink

You don't think there's a way to detect the VM version?

0
Comment actions Permalink

Oops, my bad, there is indeed no need in IDEA running under jdk6.

0

Please sign in to leave a comment.