How do I select a project's error profile?

The new settings dialog is so very unintuitive.
Seems the goal was to minimize the number of buttons in the dialog at all cost.

Ok, I have learned that to see my project's global (module independent) settings,
I have to
- select "Project Settings" in the tree (fine)
- then select "Project Roots": What the hell has my project's language level to do with project roots?
- But it's getting weirder: I have to click on "Modules" in the next tree. Pardon me: I want to change project wide settings and have to click on modules?!

Anyway - I have an actual problem that caused this rant:
Where, oh where have you hidden the setting to change the current project's active error profile?

I can click on "Project Settings -> Errors" to see both IDE (?) and project specific Error profiles. But then every project profile simply says "(inactive)".
So: How do I make it active?

5 comments
Comment actions Permalink

Hello Stephen,

Project Settings -> Errors -> Project Profiles and activate project profiles.

Do you want to find project profiles in Project Roots? Or I misunderstand
you?

Thank you.

-


Anna Kozlova
JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

The new settings dialog is so very unintuitive.
Seems the goal was to minimize the number of buttons in the dialog at
all cost.
Ok, I have learned that to see my project's global (module
independent) settings,

I have to

- select "Project Settings" in the tree (fine)

- then select "Project Roots": What the hell has my project's language
level to do with project roots?

- But it's getting weirder: I have to click on "Modules" in the next
tree. Pardon me: I want to change project wide settings and have to
click on modules?!

Anyway - I have an actual problem that caused this rant: Where, oh
where have you hidden the setting to change the current project's
active error profile?

I can click on "Project Settings -> Errors" to see both IDE (?) and
project specific Error profiles. But then every project profile simply
says "(inactive)".

So: How do I make it active?



0
Comment actions Permalink

"... and activate project profiles."

And where the heck is that "activate" feature?
There's no button in the UI that I can discover.
Right clicking on a project profile also does not show any "actiavte" context menu item.

"Do you want to find project profiles in Project Roots? Or I misunderstand
you? "
I just think it's strange
- to find IDE profiles filed under "Prohect Settings".
- to find project wide settings filed under "modules"

0
Comment actions Permalink

Hello,

Select project profile in combobox instead of ]]>.

-


Anna Kozlova
JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

"... and activate project profiles."

And where the heck is that "activate" feature?
There's no button in the UI that I can discover.
Right clicking on a project profile also does not show any "actiavte"
context menu item.
"Do you want to find project profiles in Project Roots? Or I
misunderstand
you? "
I just think it's strange
- to find IDE profiles filed under "Prohect Settings".
- to find project wide settings filed under "modules"



0
Comment actions Permalink

Arg. For a while I have been thinking we are talking about completely different dialogs.
It never occured to me to click on the "Project Profiles" tree node itself.
I wanted to activate the project profile "foo", so I clicked on that one left and right and middle.
There really should be an item in the context menu for profile "Activate this profile".
Plus maybe also a button in each profile's page "activate".

0
Comment actions Permalink

Stephen,

Will be context menu + toolbar action. I didn't understand you too :)

Thanks.

-


Anna Kozlova
JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

Arg. For a while I have been thinking we are talking about completely
different dialogs.
It never occured to me to click on the "Project Profiles" tree node
itself.
I wanted to activate the project profile "foo", so I clicked on that
one left and right and middle.
There really should be an item in the context menu for profile
"Activate this profile".
Plus maybe also a button in each profile's page "activate".



0

Please sign in to leave a comment.