Ant property changes not getting picked up

I've just noticed this with build #5594- May have been there aerlier though...

I am editing an Ant file, and in that file I reference a property as in ${my.property}. If my.property is not defined, it shows up in red, as expected.

The problem is this: If I go to the spot of the property name in the editor and modify it to reference a valid property name, the error highlighting doesn't go away. In fact, part of the property name is sometimes highlighted in red, and not necessarily the whole identifier. Additionally, if I hold the mouse over the error and look at the status line at the bottom of my screen, the error message still reflects the unchanged (and invalid) property name.

It seems as if my change to the property name never triggers a re-analysis of the ant file for errors.

2 comments
Comment actions Permalink

Hello Tim,

Could you please file a JIRA issue for this problem?

TD> I've just noticed this with build #5594- May have been there aerlier
TD> though...
TD>
TD> I am editing an Ant file, and in that file I reference a property as
TD> in ${my.property}. If my.property is not defined, it shows up in
TD> red, as expected.
TD>
TD> The problem is this: If I go to the spot of the property name in the
TD> editor and modify it to reference a valid property name, the error
TD> highlighting doesn't go away. In fact, part of the property name is
TD> sometimes highlighted in red, and not necessarily the whole
TD> identifier. Additionally, if I hold the mouse over the error and
TD> look at the status line at the bottom of my screen, the error
TD> message still reflects the unchanged (and invalid) property name.
TD>
TD> It seems as if my change to the property name never triggers a
TD> re-analysis of the ant file for errors.

--
Dmitry Jemerov
Software Developer
http://www.jetbrains.com/
"Develop with Pleasure!"


0

Please sign in to leave a comment.