Web server specific libraries

I have two libraries that are specific to my application server. They
are defined under the application server.


This used to work in IJ5, but in IJ6 I get syntax errors like it doesn't
see the server.


Do those now have to be added separately instead of being pulled in when
the server is chosen?



Attachment(s):
moz-screenshot-1.jpg
moz-screenshot-2.jpg
4 comments
Comment actions Permalink

The problem is that you don't associate a specific server to the module anymore - the server is only part of the run configuration. So there's no possibility to access server specific libraries from within the module.

0
Comment actions Permalink

That is what I figured. Thanks for the info.

Martin Fuhrer wrote:

The problem is that you don't associate a specific server to the module anymore - the server is only part of the run configuration. So there's no possibility to access server specific libraries from within the module.

0
Comment actions Permalink

Wow. Am I the only one who had to search to find out how to add a library?

Norris Shelton wrote:

That is what I figured. Thanks for the info.

>

Martin Fuhrer wrote:

>> The problem is that you don't associate a specific server to the
>> module anymore - the server is only part of the run configuration. So
>> there's no possibility to access server specific libraries from
>> within the module.
>>

0
Comment actions Permalink

Hello Norris,

Go to Settings | Project Roots | ]]> | Classpath tab, press "Add..."
button, select "Add application server library".


0

Please sign in to leave a comment.