TOMCAT 6 not recognised by IntelliJ 9.0.2 on opensuse 11.3

Hi, I am having a little difficulty in configuring tomcat 6 by using IntelliJ 9 on opensuse 11.3. I have evaluated windows version with which it works perfectly well.
My Tomcat 6 is intalled at /usr/share/tomcat6, I also have defined CATALINA_HOME and JDK_HOME env variables appropriately in opensuse 11.3. After selecting tomcat server in application server, it asks for /usr/share/tomcat6/common/lib folder which was the case for Tomcat5.x and Tomcat 6 has a different directory structure.

I tried to supply common and then lib folders, but it results in IntelliJ recognizing it as Tomcat 5.x server which is not the case. Please help me by sugegsting a workaround for this problem!

Kind Regards

Zubair

3 comments
Comment actions Permalink

Does /usr/share/tomcat6/lib/servlet-api.jar file exist in your system? IDEA uses that file to detect version 6 of Tomcat.

Hi, I am having a little difficulty in configuring tomcat 6 by using IntelliJ 9 on opensuse 11.3. I have evaluated windows version with which it works perfectly well.
My Tomcat 6 is intalled at /usr/share/tomcat6, I also have defined CATALINA_HOME and JDK_HOME env variables appropriately in opensuse 11.3. After selecting tomcat server in application server, it asks for /usr/share/tomcat6/common/lib folder which was the case for Tomcat5.x and Tomcat 6 has a different directory structure.

>

I tried to supply common and then lib folders, but it results in IntelliJ recognizing it as Tomcat 5.x server which is not the case. Please help me by sugegsting a workaround for this problem!

>

Kind Regards

>

Zubair

>

---
Original message URL: http://devnet.jetbrains.net/message/5267814#5267814



--
Nikolay Chashnikov
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

0
Comment actions Permalink

Thanks Nikolay, worked for me after I coped servlet-api.jar from idea_installation_folder/lib to usr/share/tomcat6/lib.
Regards
Zubair

0
Comment actions Permalink

I had a similar issue on Scientific Linux 6.2 when installing tomcat6 from RPM -- servlet-api.jar is installed as tomcat6-servlet-2.5-api-6.0.24.jar, so IDEA gets confused. I added a symlink and that fixed the problem.

0

Please sign in to leave a comment.