IDEA 11 slow, editor lags

First of all I want to say thank you for developing Intellij IDEA it's great IDE.

Last versions are not so stable and fast as previous. So we decided to upgrade from 8.1.x to 11.0.x. (reworked indexing engine, multithreading, Java 7 support)

I experienced lags when typing (delays: autocomplete 500ms, param info: 1s, no show doc, autoreparse: 500ms). IDE in power save mode works like 'Visual' NOTEPAD from Windows - disabled almost all checks - so not very usable. Even just moving text cursor around source code need up to 70% on signle core slow machine (millions of char[] allocations).

Inspect code on module is several times slower than 8.1.x (same project and settings). Insection by name after run is disabled and can't be restarted.

Please is it possible to improve IDEA? Thank you very much.

  Martin


IDE runs on linux 2.6.x, 3.1.x (kernel), Java 6u30 i586, Java 7u2 i586, x86_6, Graphics acceleration enabled, working (nVidia drivers)

Machine types:
1: AMD 64, 1800MHz 1 core, 2GB, Xmx640M
2: Intel 4 core (no HT), 8GB, Xmx640M

Projects: Java SE 6/7
LOC: ~60 000, > 4MB, >6 modules in projects

15 comments
Comment actions Permalink

Please submit a CPU snapshot as described in
http://devnet.jetbrains.net/docs/DOC-192

0
Comment actions Permalink

I would like just to re-confirm from my side, that intellij-11 become terribly slow in the editor.
Switching to Power Save mode make it faster (and mostly like a slow Notepad) so it's not a solution
I really can't work now - just typing become a pain.
and it seems it is not only the editor - the whole Intellij-Idea seems to be s-o-o-o  sl-o-o-o-w

0
Comment actions Permalink

Please submit a CPU snapshot as described in http://devnet.jetbrains.net/docs/DOC-192

0
Comment actions Permalink

Idea 11.0.2 is performing inspections 'indefinitely'. Testing on linux, JDK 7u4b13 64bit. JDK 7u2 is similar.

Linux linux-tp9a 2.6.25.20-0.4-default #1 SMP 2009-06-01 09:57:12 +0200 x86_64 x86_64 x86_64 GNU/Linux
Java HotSpot(TM) 64-Bit Server VM (build 23.0-b16, mixed mode)

Last operation: Refactoring: move UNUSED inner class to upper level. Uncommented line with instatiation of refactored class.

Performing code analysis: Inspections: 99%, Slow inspections: 100%. 26 warnings, 3 typos.

File: JFrame implementation - 4096 LOC
Project: 3.8MB in 615 .java files

Attached 2 screenshots from JVisualVM CPU sampling. Delay ~10 minutes

  Martin



Attachment(s):
ss-idea-11-0-2-2.png
ss-idea-11-0-2.png
0
Comment actions Permalink

This looks like http://youtrack.jetbrains.com/issue/IDEA-81509 which is fixed in IntelliJ IDEA 11.1.

0
Comment actions Permalink

I'm trying IU-114.243 - it's better but still there are some lags when typing. (Now working on same project but not changing original huge file). I will collect and send CPU usage data when major slowdown occurs.

  Thank you
  Martin

0
Comment actions Permalink

IU 114.243 Cpu snap shot:
State: closed all source editors

Snapshot recorded for following steps:
1) open huge JFrame file (~4000LOC)
2) Ctrl+F
3) add one line at line ~2100
4) wait till analysis is complete



Attachment(s):
IU-114.243_jandam_05.03.2012_13.41.28.zip
0
Comment actions Permalink

Hi

I've experienced the EXACT same behaviour and I think I have found the root cause.
The screenshot I've attached shows the method that eats the CPU.

By disabling "Constant conditions & exceptions" and "@NotNull/@Nullable problems" from the inspection profile,
the problem disappears and the inspection analysis no longer stays at 99%.

#EDIT:  I'm using version 117.84 on Ubuntu 11.10 64-bit.


Regards
Yusuf



Attachment(s):
cpu_snapshot.png
0
Comment actions Permalink

Hi,

I'm testing 11.1 Ultimate and the only way to get acceptable editor speed is to disabling the maven plugin. But this isn't the solution I need.

Cheers
Torsten

0
Comment actions Permalink

Hi Torsten,

Please provide your CPU snapshot then.

Denis

0
Comment actions Permalink

Does the problem persist if you turn off svn plugin?

Denis

0
Comment actions Permalink

No, no changes. It's definitly maven. Everytime it hangs 11.1 is doing mvn stuff like Importing Maven projects, also when you do nothing it's always triggering the import.

0
Comment actions Permalink

Thanks!

I've created a corresponding ticket - IDEA-83697.

Denis

0
Comment actions Permalink

IDEA 11.1 is getting slower and slower even when MAVEN is turned off. Project with SVN = ON.

Usage steps:
- open one project
- edit code
- reopen second project in new window
- copy one source file to Clipboard and compare with file from other project

Both projects are under SVN. Just switching between windows makes IDEA unusable because project is saved on EDT that means almost unusable window for second project. This is already reported (comment: saving project on EDT is feature of IDEA)

Switching off SVN helps but don't solve all slowdowns.

  Martin

PS thank you very much for best IDE for Java. If you can please focus on stability and performance instead of implementing new features and new languages.

0

Please sign in to leave a comment.