5321 : Unrecognized option: -agentlib:yjpagent

Hi,
i'm trying to upgrade to 5321, but i am getting this exception when i run idea.bat. Running the idea.exe does not help as it loads the flash screen and ends there.

When i remove the option i get another exception :

Exception in thread "main" java.lang.UnsupportedClassVersionError: com/intellij/idea/Main (Unsupported major.minor version 49.0)
at java.lang.ClassLoader.defineClass0(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:539)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:123)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:251)
at java.net.URLClassLoader.access$100(URLClassLoader.java:55)
at java.net.URLClassLoader$1.run(URLClassLoader.java:194)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:187)
at java.lang.ClassLoader.loadClass(ClassLoader.java:289)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:274)
at java.lang.ClassLoader.loadClass(ClassLoader.java:235)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:302)

Anyone have an idea, how to overcome this issue ?

Thanks
Sipho

4 comments
Comment actions Permalink

Hello sipho,

You need to run Demetra with JDK version 5, not with an earlier version.

--
Dmitry Jemerov
Software Developer
http://www.jetbrains.com/
"Develop with Pleasure!"

s> Hi, i'm trying to upgrade to 5321, but i am getting this exception
s> when i run idea.bat. Running the idea.exe does not help as it loads
s> the flash screen and ends there.
s>
s> When i remove the option i get another exception :
s>
s> Exception in thread "main" java.lang.UnsupportedClassVersionError:
s> com/intellij/idea/Main (Unsupported major.minor version 49.0)
s> at java.lang.ClassLoader.defineClass0(Native Method)
s> at java.lang.ClassLoader.defineClass(ClassLoader.java:539)
s> at
s> java.security.SecureClassLoader.defineClass(SecureClassLoader.java:12
s> 3)
s> at
s> java.net.URLClassLoader.defineClass(URLClassLoader.java:251)
s> at java.net.URLClassLoader.access$100(URLClassLoader.java:55)
s> at java.net.URLClassLoader$1.run(URLClassLoader.java:194)
s> at java.security.AccessController.doPrivileged(Native Method)
s> at java.net.URLClassLoader.findClass(URLClassLoader.java:187)
s> at java.lang.ClassLoader.loadClass(ClassLoader.java:289)
s> at
s> sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:274)
s> at java.lang.ClassLoader.loadClass(ClassLoader.java:235)
s> at
s> java.lang.ClassLoader.loadClassInternal(ClassLoader.java:302)
s> Anyone have an idea, how to overcome this issue ?
s>
s> Thanks Sipho
s>


0
Comment actions Permalink

You need to run Demetra with JDK version 5, not with an earlier version.


That would mean that you can't run it under any version of MacOS before 10.4 since version 5 of the JDK is only available in Tiger.

Thank goodness I was finally able to upgrade!

Donald

0
Comment actions Permalink

Hi i am running on 1.5 as u can see below :

\IntelliJ IDEA 5321\bin>java -version
java version "1.5.0_04"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_04-b05)
Java HotSpot(TM) Client VM (build 1.5.0_04-b05, mixed mode, sharing)

Thanks
sipho

0
Comment actions Permalink

Yes, but is your IDEA_JDK environment variable pointing to the correct JDK?

0

Please sign in to leave a comment.