Odd Problem with MultiModule project in 5218

I have this strange problem that recently surfaced.

I have a multi module project, with java modules, ejb modules, and an app module.

In one of the EJB modules, I tried to open up a folder (package) in the project tree view. When I did so, it responded with the loading... message, but never actually completed loading.

After that, I am unable to open up any other folder that contains java code, in any module within the project.

I have created a new project, and imported the modules but the same problem re-occurred. I deleted all modules and then reimported everything but the problem EJB module. That one I created a new module (but for the same source). Same problem.

There is nothing special in this package -- just 3 java files. All are current with svn repository.

Note that I use subversion integration, if that may be involved.

Has this been seen before? Is there anything I can do?

Thanks,
ken clark

3 comments

Minor update:

I found that I could open the folder after removing the src from the path settings.

Then I tried moving the files to a brand new EJB module. I can do this. But, when I try to open the new package where the files are now located, the same thing happens.

What is strange is how badly this screws up the project. Once I have done this once, I am no longer able to view any java files from the project tree view -- even after closing and reopening the project.

The only way to recover the project is to delete every single module in it, then close it, then reopen it, then re-import every module. Once done, I am able to work normally again.

I have zipped up all the files in the module for anyone who wishes to test this problem out.

ken clark



Attachment(s):
SampleEJB1.zip
0

I loaded this up in 5.1 and had no problems with it -- I can view the same files fine.

0

Was anyone ever able to reproduce this (or fix it) in the EAP?

Thanks,
ken

0

Please sign in to leave a comment.