EAP 11.1 Flash Setup Broken

So this has turned into a mess after update. Everything looked like how i wished it would be organized but then nothing is working right.

If i right click on a module in thr project structure and select New -> Build Configuration
No matter what i select for target platform either Desktop of Mobile whenever i hit ok it always changes it to Web. So essentially i cant pick anything but web.

Luckily when i opened an old project it did create a desktop run configuration that i can use, but apparently i'm not able to create one of my own?!

Secondly it seems you havce removed the make option from remote flash debug. I was using remote debug to make a module for me then use ANT to launch the AIR application with an ANE.
Is there another way to have a run configuration make a module then just run an ant task instead of laucnhing a swf?

So far the structure looks good, but removing that option and the fact that nothing seems to be working right its hard to tell for sure

Im running Nika.1 114.98

any ideas?
-ross

2 comments
Comment actions Permalink

We are very sorry for the critical bug in IDEA 114.98: indeed, all build configurations are reset to defaults in Project Structure. EAP with the fix will be published today.

We believe in most of cases option to compile before remote debug is not relevant. I hope when we'll implement ANE support in IDEA you won't need to use ant any more. For now you need to compile using some other way - either Make the whole project or only selected module (the option is in the module node context menu in Project view or Navigation bar).

0
Comment actions Permalink

Official ANE support would be the best option for sure, very excited for that.

I will test the new build for flash structure whenever you guys can get it out here.

In other news I have never been able to get ANT Build properties to work correctly for "some" variables.

For exmaple if i make this target

 <target name="test">
 <echo message="${IMOD_ROOT}"/>
 </target>



Right click on my ANT build select properties then ADD

add the following
IMOD_ROOT -- $ModuleFileDir$

Inside the macro preview this looks correct, but when i run this ant target it echos nothing. Some macros work, but it seems specifically the ones refering to a module do not. I also seem to be noticing mixed results depending on how I run ther target. If it is run as a "Before Launch" i get different results then just running it by double clicking. Regardless I can never get Module Path Macros to contani anything. Any Ideas on that one?
0

Please sign in to leave a comment.