Ignored directory?

Has anyone seen anything like this? In the latest EAP, I have a directory called 'common', with a source under it and so on, yet no matter what I do, it doesn't show up in IDEA, it's completely ignored. Of course, it shows up fine in 5.1. The dir doesn't have anything special (that I know of), and there's nothing of interest in any idea logs to investigate. So...any thoughts on how to get my poor source dir showing up, or even what sort of info I should provide in a bug report?

4 comments

Hello Hani,

The only idea I have you probably configured this directory to be compiler
output path or exploded directory or explicitly excluded it in some module
configuration.
There was a bug in 5.1 that prevented compiler output paths from being excluded
if actually reside in content directory of another module, not the one it
aimed to store classes from.

-


Maxim Shafirov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0

Hi Maxim,

It is an output dir, but I have 'exclude output dir' unchecked in all modules. Yet it doesn't show up.

0

Hello Hani,

I'll take a look, thanks

-


Maxim Shafirov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Hi Maxim,

It is an output dir, but I have 'exclude output dir' unchecked in all
modules. Yet it doesn't show up.



0

Hi Maxim,

I figured it out. It was indeed excluded, but the behaviour is slightly different to 5.1. I have different modules point to the same output dir. Previously if any of them didn't exclude it, it showed up. Now if any of them exclude it, it doesn't. No biggie, but it is a change from 5.1!

0

Please sign in to leave a comment.