debugging with JBoss

Using 5218: What do I have to do to connect the debugging
to a JBoss (4.0.4RC1) already running on the local machine?

I created a JSR45 Compatible Server -> Remote Configuration
in Idea.

I modified the startup options in the JBoss start script:
set JAVA_OPTS=%JAVA_OPTS% -ea -Xms128m -Xmx768m -XX:MaxPermSize=192m -Xdebug -Xnoagent -Djava.compiler=NONE -Xrunjdwp:transport=dt_socket,address=2570,suspend=n,server=y

When I try to debug from Idea, all I ever get is a message
box saying
"Error running JBoss: Unable to open debugger port: java.netConnectException "Connection refused: connect"

I have my firewall switched off.

I know about the JBoss plugin. But all I want to do is to
connect to a JBoss instance that is already running.
Idea should be able to do that out of the box, shouldn't it?

2 comments

Hello Stephen,

It seems to me that your run settings is not configured correctly.

You must specify:
1) debugger's listening port (2570 in your configuration) in "Startup/Connection"
tab | Debug | "Port" field.
2) JBoss server port (8080 by default) in "Server" tab | "Remote Connection
Settings" group | "Port" field.
3) "localhost" in "Server" tab | "Remote Connection Settings" group | "Host"
field.
4) "org.apache.jsp" in "Server" tab | "JSP's package" field.
5) any nonempty string in "VM options variable" (this text field and the
"Port" field just under it are not used in remote configuration)

Using 5218: What do I have to do to connect the debugging to a JBoss
(4.0.4RC1) already running on the local machine?

I created a JSR45 Compatible Server -> Remote Configuration in Idea.

I modified the startup options in the JBoss start script:

set JAVA_OPTS=%JAVA_OPTS% -ea -Xms128m -Xmx768m -XX:MaxPermSize=192m
-Xdebug -Xnoagent -Djava.compiler=NONE
-Xrunjdwp:transport=dt_socket,address=2570,suspend=n,server=y

When I try to debug from Idea, all I ever get is a message

box saying

"Error running JBoss: Unable to open debugger port:
java.netConnectException "Connection refused: connect"

I have my firewall switched off.

I know about the JBoss plugin. But all I want to do is to
connect to a JBoss instance that is already running.
Idea should be able to do that out of the box, shouldn't it?

---
Nikolay Chashnikov
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0

That really seems like the hard way to do it. Just use the JBoss
plugin. It is an excellent solution.

Nikolay Chashnikov (JetBrains) wrote:

Hello Stephen,

>

It seems to me that your run settings is not configured correctly.

>

You must specify:
1) debugger's listening port (2570 in your configuration) in
"Startup/Connection" tab | Debug | "Port" field.
2) JBoss server port (8080 by default) in "Server" tab | "Remote
Connection Settings" group | "Port" field.
3) "localhost" in "Server" tab | "Remote Connection Settings" group |
"Host" field.
4) "org.apache.jsp" in "Server" tab | "JSP's package" field.
5) any nonempty string in "VM options variable" (this text field and
the "Port" field just under it are not used in remote configuration)

>
>
>> Using 5218: What do I have to do to connect the debugging to a JBoss
>> (4.0.4RC1) already running on the local machine?
>>
>> I created a JSR45 Compatible Server -> Remote Configuration in Idea.
>>
>> I modified the startup options in the JBoss start script:
>>
>> set JAVA_OPTS=%JAVA_OPTS% -ea -Xms128m -Xmx768m -XX:MaxPermSize=192m
>> -Xdebug -Xnoagent -Djava.compiler=NONE
>> -Xrunjdwp:transport=dt_socket,address=2570,suspend=n,server=y
>>
>> When I try to debug from Idea, all I ever get is a message
>>
>> box saying
>>
>> "Error running JBoss: Unable to open debugger port:
>> java.netConnectException "Connection refused: connect"
>>
>> I have my firewall switched off.
>>
>> I know about the JBoss plugin. But all I want to do is to
>> connect to a JBoss instance that is already running.
>> Idea should be able to do that out of the box, shouldn't it?

---
Nikolay Chashnikov
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>
>

0

Please sign in to leave a comment.