Anti-aliasing IDEA

What is the secret to get a nicely anti-aliased IDEA on Linux? I've read a
few previous posts on the topic but nothing really helped get something
decent.

I'm running 4171 and 5201 on a relatively recent kubuntu with KDE 3.4.0.
Java is 1.6.0-beta2 build 76.
I have IDE Settings -> Appearance -> Use antialiased font in editor == true
Look and feel: Alloy. Glass Theme
default fonts NOT overridden

I have "-Dswing.aatext=true" in idea.vmoptions.

The editor text looks good, but everything else is painful to look at. Menus
look hideous. All dialogs, toolwindows, etc are not anti-aliased.

What's the secret? Is there hope? With more and more people working with
LCDs I think it'd be worth getting that to work.

Thanks,

Vince.


4 comments

If you mean subpixel antialiasing, it does not work in KDE, only in Gnome and other GTK environments (XFCE for example). I solved this problem with the patch, that is located somwhere here on the forum (aahack.jar).

But it antialiases only editor. Menus are aliased. I set up good font (tahoma, 11pt) and it looks good. Antialiasing, as I understand, must be supported by look and feel, and it's done only for metal and native (GTK for linux) ones... Old Idea 4.5 also is antialiased (not totally).

So as I understand there is no solution now.

0

For KDE, you have to tell the VM to do antialiasing (it doesn't recognize KDE's settings), so setting:

awt.useSystemAAFontSettings=lcd_vbrg

Worked nicely for me.

0

I almost regained hope here..
But it didn't do anything for me. I tried several options as listed in
http://java.sun.com/javase/6/docs/guide/2d/flags.html#aaFonts
("lcd_vbrg" wasn't one of them though) but aboslutely nothing changed. Ugly
everything but editor and about dialog

Just to confirm that I'm not doing something really stupid on a Friday, I
added
-Dawt.useSystemAAFontSettings=lcd_vbgr
to my idea.vmoptions.

Why does it have to be so ugly!

Vince.


0

Please sign in to leave a comment.