Default "create field" initialization

Answered

Whenever I do "create field" refactoring, 95% of the time I want it done in the current method, but intellij defaults to field declaration.  Perhaps a minor issue, but it gets frustrating because I need to leave the keys and start messing around with the mouse again.  Also, when you first do it, you'll get suggested names in a drop down.  If you select one, you can't change "initialize in".  If you select "Initialize in" first, the suggested names drop down goes away.  Again, minor point, but it gets magnified because I'm doing it all day (Android dev).

Thoughts?  Is there a "suggest a feature" page?

5 comments
Comment actions Permalink

Press Alt-I to toggle "Initialize in" from the keyboard.

0
Comment actions Permalink

The thing is Alt-I brings ^, instead of toggling "initialize in". Any ideas?

 

0
Comment actions Permalink

Make sure you do not have File | Settings | Appearance & Behavior | Appearance | Window Options | Disable mnemonics in controls enabled.

If it does not help and  your OS is OS X, see also https://stackoverflow.com/a/44543906/2000323 (using Ctrl+Alt).

0
Comment actions Permalink

Thank you for a prompt reply!

 

I do have this option disabled.

My OS is macOS and I actually can use Ctrl+Alt, but can't Alt only. I checked the custom settings mentioned in SO answer, but no luck.

0

Please sign in to leave a comment.