How to enable code coverage?

Hi Idea developers,
how do I enable the code coverage in Build 5181? In the according tab the "Enable code coverage" checkbox as well as everything else is always disabled.
I tried with adding the emma-.jars to the module's classpath, then I get (for a single class test run configuration) the class' package name appended by "." in the (still disabled) checkbox-list - which doesn't help much, but at least something happens ;)

When trying to access Analyze -> Show Coverage Info I always get a popup that no coverage has been gathered for that file.

What am I doing wrong?

Thanks,
Axel

5 comments

Hello Axel,

You're probably have JDK 1.4 assigned to the project while coverage is only
supported for 1.5 to the date. We're discussing possibility to implement
the stuff for 1.4.

-


Maxim Shafirov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0

Ah, right. With jdk 1.5 it works.

Would be great if code coverage would also work for jdk 1.4. AFAIK emma also works for 1.4.

Thanks again,
Axel

0

emma does work with jdk 1.4 with usual jdk 1.4 limitations: since instrumentation is done with class loader mechanism, you won't get any coverage for applications substituting custom class loaders. Since this is exactly the case with IDEA itself and for egoistic reasons we chose to provide coverage with 1.5 agents first:)

Eugene.

0

sorry for asking a dumb question but where is this "enable code coverage" toggle? Options dialog search is resulting in messed up displays and going thru all the options one-by-one, I could not find this toggle. I can see the Analyze->Code Coverage Info menu but not the toggle.

0

As I said - sorry for the dumb questions - got it thanks

0

Please sign in to leave a comment.