IntelliJ crash opening Java files

When I open any Java file within IntelliJ 11, it crashes. I mean the window suddenly disappears.
I'm using Fedora 16 (Gnome 3), JDK 1.6.0_30 (it was the same with 1.6.0_27).
I attached the log file, the first part is the following:

#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x4f2c353d, pid=21181, tid=1966455616
#
# JRE version: 6.0_30-b12
# Java VM: Java HotSpot(TM) Server VM (20.5-b03 mixed mode linux-x86 )
# Problematic frame:
# C  [libgcrypt.so.11+0x2b53d]  __snprintf_chk+0x2b53d
#
# If you would like to submit a bug report, please visit:
#   http://java.sun.com/webapps/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#


I already submitted a bug to Sun, is there anyone with the same problem and maybe a work around for this?

Thanks in advance


Attachment(s):
hs_err_pid21181.log.zip
5 comments
Comment actions Permalink

Forgot to mention that I'm running the kernel 3.1.8-2.fc16.i686.PAE and the jdk I'm using is 32 bit.
Furthermore, I noticed the problem is related to any kind of files, not just Java files.

0
Comment actions Permalink

This is most likely a bug in the SVNKit library, not in the JDK. The workaround is to disable the Subversion integration.

0
Comment actions Permalink

Good shot!

I disabled the Subversion integration and everything works for now.

Thanks for the quick answer!

0
Comment actions Permalink

The SVNKit developer says:

Looks like SVNKit Gnome Keyring support only works with Gnome 2, not
Gnome 3 yet.

To disable Gnome Keyring support in SVNKit, put the following line
into Subversion configuration file (default is at
~/.subversion/config, IDEA might use ~/.subversion_IDEA/config, but
I'm not sure):

password-stores=

Another way to disable Gnome Keyring support in SVNKit is to set the
following system property:

svnkit.library.gnome-keyring.enabled=false
0
Comment actions Permalink

Thanks a lot, again!

I added the suggested line within the [auth] section of the subversion config file and after re-enabling the Subversion intergration, IntelliJ doesn't crash anymore.

0

Please sign in to leave a comment.