idea5131 : pb on j2sdk1.4.2_10, WinXP

i dowloaded and tried to run idea5131.zip 48,555,276 bytes (Windows pack, no JRE)

1)

idea
Unrecognized option: -agentlib:yjpagent
Could not create the Java virtual machine.
]]>

ok, removed -agentlib:yjpagent from idea.exe.vmoptions

2)

idea
Exception in thread "main" java.lang.UnsupportedClassVersionError: com/intellij/idea/Main (Unsupported major.minor version 49.0)
        at java.lang.ClassLoader.defineClass0(Native Method)
        at java.lang.ClassLoader.defineClass(ClassLoader.java:539)
        at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:123)
        at java.net.URLClassLoader.defineClass(URLClassLoader.java:251)
        at java.net.URLClassLoader.access$100(URLClassLoader.java:55)
        at java.net.URLClassLoader$1.run(URLClassLoader.java:194)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:187)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:289)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:274)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:235)
        at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:302)
]]>

java -version
java version "1.4.2_10"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2_10-b03)
Java HotSpot(TM) Client VM (build 1.4.2_10-b03, mixed mode)

C:\idea5131\bin>set IDEA_JDK
IDEA_JDK=C:\j2sdk1.4.2_10
]]>

any idea? compiled with jdk1.5 ?

7 comments

Hello Mikhail,

MK> i dowloaded and tried to run idea5131.zip 48,555,276 bytes
MK> (Windows pack, no JRE)
MK>
MK> any idea? compiled with jdk1.5 ?

Yes, IDEA 6.0 requires JDK 1.5. You will need to install the new JDK.

--
Dmitry Jemerov
Software Developer
JetBrains, Inc.
http://www.jetbrains.com
"Develop with pleasure!"


0

Hi Dmitry,

Yes, IDEA 6.0 requires JDK 1.5. You will need to install the new JDK.


Could IDEA have a bootstrap class compiled for 1.4 that would inform anyone
trying to use 1.4 that they need 1.5? It would give a much better experience
and save you a lot of work in support :)

Vince.


0

You should at least update the download page
http://www.intellij.net/eap/products/idea/download.jsp where JDK 1.4 is
explicitly mentioned as a valid JDK for IDEA.

Vincent Mallet wrote:

Hi Dmitry,

>> Yes, IDEA 6.0 requires JDK 1.5. You will need to install the new JDK.


Could IDEA have a bootstrap class compiled for 1.4 that would inform anyone
trying to use 1.4 that they need 1.5? It would give a much better experience
and save you a lot of work in support :)

Vince.


--
Martin Fuhrer
Fuhrer Engineering AG
http://www.fuhrer.com

0

You should at least update the download page
http://www.intellij.net/eap/products/idea/download.jsp
where JDK 1.4 is
explicitly mentioned as a valid JDK for IDEA.


That page is about the released version, and IDEA 5.1 runs fine on JDK 1.4. Demetra, however, needs 1.5.

0

No, that page is about the current EAP version - build 5131 actually.

(Build number 51xx doesn't mean IDEA 5.1, this match is sheer
coincidence. IDEA 5.1 has build number 4155.)

Marcus Brito wrote:
>> You should at least update the download page
>> http://www.intellij.net/eap/products/idea/download.jsp
>> where JDK 1.4 is
>> explicitly mentioned as a valid JDK for IDEA.


That page is about the released version, and IDEA 5.1 runs fine on JDK 1.4. Demetra, however, needs 1.5.


--
Martin Fuhrer
Fuhrer Engineering AG
http://www.fuhrer.com

0

Hello Martin,

Done.

MF> You should at least update the download page
MF> http://www.intellij.net/eap/products/idea/download.jsp where JDK 1.4
MF> is explicitly mentioned as a valid JDK for IDEA.
MF>
MF> Vincent Mallet wrote:
MF>
>> Hi Dmitry,
>>
>>> Yes, IDEA 6.0 requires JDK 1.5. You will need to install the new
>>> JDK.
>>>
>> Could IDEA have a bootstrap class compiled for 1.4 that would inform
>> anyone trying to use 1.4 that they need 1.5? It would give a much
>> better experience and save you a lot of work in support :)
>>
>> Vince.
>>
--
Dmitry Jemerov
Software Developer
JetBrains, Inc.
http://www.jetbrains.com
"Develop with pleasure!"


0

No, that page is about the current EAP version -
build 5131 actually.


Oops. My bad.

0

Please sign in to leave a comment.