Can't compile/make/build

Is anyone else having an issue with compiling under java 1.3?

I keep getting an error message that says:
Error: javac: invalid flag: -source

Problem is, I don't see where I am telling the compiler to use -source.

I have tried to compile the individual file, make project, make module, and rebuild project, all with no luck.

Am I missing a setting somewhere?

8 comments

Hello zmbs,

Is anyone else having an issue with compiling under java 1.3?

I keep getting an error message that says:
Error: javac: invalid flag: -source
Problem is, I don't see where I am telling the compiler to use
-source.

I have tried to compile the individual file, make project, make
module, and rebuild project, all with no luck.

Am I missing a setting somewhere?


For some reason IDEA thinks that the configured JDK is not 1.3 version and
is specifying -source option according to Settings | Modules | Language Level
for Project. The solution is to reinstall the JDK, add the new JDK entry
in IDEA for the installed JDK and then make sure that Language Level is set
to 1.3 in Settings | Modules | Paths.

--
Serge Baranov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0

I tried adding a new JDK and picking it for the module, no luck.

I reinstalled 1.3, in a new directory, added it to IDEA, and picked it for the module, and no luck.

I tried change the level to 1.3 to 1.4, restarting, then changing from 1.4. to 1.3 and restarting, and can't compile.

The language level says 1.3(I have verified it over and over and over and over again, just to be sure), and I keep getting the same message.

Not sure what else to try.

Also,I am using 1.3.1_16, in case that makes any difference.

0

And, I just tried making a whole new project, from scratch(instead of reusing the existing 5.1 project), and still, no luck.

0

Could you please send me your zipped config folder?

--
Best regards,
Eugene Zhuravlev
Software Developer
JetBrains Inc.
http://www.jetbrains.com
"Develop with pleasure!"

"zmbs" <no_mail@jetbrains.com> wrote in message news:5752789.1139409762072.JavaMail.itn@is.intellij.net...

And, I just tried making a whole new project, from scratch(instead of reusing the existing 5.1 project), and still, no luck.



0

Hi,

The same problem on my side.
I switched to eclipse compiler and problem has gone away. Not a good solution, just a workaround.

0

Fixed

--
Best regards,
Eugene Zhuravlev
Software Developer
JetBrains Inc.
http://www.jetbrains.com
"Develop with pleasure!"


0

Actually, yours was a duplicate of mine. :) But, what is important is that it got fixed...yeah! :)

0

Please sign in to leave a comment.