Buil 4148 is slow? Using lots of CPU when idle?

Is build 4148 slow for anyone else? Its using a lot of CPU time when sitting idle.

11 comments

(this is on mac os x, 10.4.4, java5)

0

Hello peter,

pr> Is build 4148 slow for anyone else? Its using a lot of CPU time when
pr> sitting idle.

CPU snapshot please?

--
Dmitry Jemerov
Software Developer
JetBrains, Inc.
http://www.jetbrains.com
"Develop with pleasure!"


0

Can you tell me, how to get these snapshots on Linux? I try to develop under gentoo linux, and sometimes debugging is veeery slow. Expecially at variables evaluation. I'll try same build on Windows, but as I remember, this is Linux' version issue.

0

CPU snapshot please?


I knew you would want this :) I searched the forums, and couldn't find how to get the toolbar button to capture one to appear when running on my Mac.
-pete

0

Hello peter,

Open /Applications/IntelliJ IDEA 5.0.app/Contents/Info.plist
edit VMOptions value by adding -Xrunyjpagent:port=10100

-


Maxim Shafirov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>> CPU snapshot please?
>>

I knew you would want this :) I searched the forums, and couldn't find
how to get the toolbar button to capture one to appear when running on
my Mac.

-pete



0

Snapshot attached.

I loaded IDEA, opened my project (it is set to not open the last project @ startup), and then took the snapshot after the tip-of-the-day screen was dismissed. (With 4137 CPU usage is minimal at this point). Looking at the memory usage indicator, it kept creeping up and jumping back, so something must have been creating objects.
-pete



Attachment(s):
4148_osi_04.02.2006_11.31.30.zip
0

Hello peter,

Snapshot shows subversion plugin is the most probable slowdown cause. Would
you please try running with this plugins removed. Do the things appear back
to normal then?

-


Maxim Shafirov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Snapshot attached.

I loaded IDEA, opened my project (it is set to not open the last
project @ startup), and then took the snapshot after the
tip-of-the-day screen was dismissed. (With 4137 CPU usage is minimal
at this point). Looking at the memory usage indicator, it kept
creeping up and jumping back, so something must have been creating
objects.

-pete



0

Snapshot shows subversion plugin is the most probable
slowdown cause. Would
you please try running with this plugins removed. Do
the things appear back
to normal then?


yup, running without the subversion plugin and things are back to the speed they should be.
-pete

0

Hello peter,

Thanks a lot. We'll investigate the issue ASAP.

-


Maxim Shafirov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>> Snapshot shows subversion plugin is the most probable
>> slowdown cause. Would
>> you please try running with this plugins removed. Do
>> the things appear back
>> to normal then?

yup, running without the subversion plugin and things are back to the
speed they should be. -pete



0

Hello peter,

Meanwhile you can try rolling back on javasvn library from previous EAPs.

-


Maxim Shafirov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>> Snapshot shows subversion plugin is the most probable
>> slowdown cause. Would
>> you please try running with this plugins removed. Do
>> the things appear back
>> to normal then?

yup, running without the subversion plugin and things are back to the
speed they should be. -pete



0

Meanwhile you can try rolling back on javasvn library
from previous EAPs.


I've just gone back to using build 4137 for the time being. Thanks!!
-peter

0

Please sign in to leave a comment.