Enabling the auto-import feature

I became quite fond of the auto-import feature in IntelliJ, but as of recently, it hasn't been working. I've flipped through all of the settings, and nothing has changed, but feature seems disabled.

Here's a screen shot of my current settings for the auto-import; as I've said, I've changed nothing. But if there's something I'm missing, I'm all ears (or eyes, technically).


http://i.imgur.com/qWu3J.png

2 comments
Comment actions Permalink

Huh?
Your screenshot shows that "Add unambiguous imports on the fly" is not enabled. So why should IDEA auto-import anything?

On 13.12.2011 05:20, Kyle Shappley wrote:

I became quite fond of the auto-import feature in IntelliJ, but as of recently, it hasn't been working. I've flipped through all of the settings, and nothing has changed, but feature seems disabled.

>

Here's a screen shot of my current settings for the auto-import; as I've said, I've changed nothing. But if there's something I'm missing, I'm all ears (or eyes, technically).

>
>

  Image:http://i.imgur.com/qWu3J.png

>

---
Original message URL: http://devnet.jetbrains.net/message/5446180#5446180


0
Comment actions Permalink

I enabled it, and restarted IntelliJ afterwords, but it's still not working.
Thanks for trying, though.

0

Please sign in to leave a comment.