Missing Incoming Changes in IDEA 10.5.2

Having problems with a large project and IDEA. Basically the project is created via the Eclipse plugin, everything appears to work apart from the Subversion intergration never shows incoming changes. It detected project level subversion support OK and shows the repository history and logs, I can evern see the history for commits not in my local copy, but incoming remains empty. Tried clearing the caches and recreating the project several times, even tried checking out a fresh copy of the project - still can't see any of the pending  incoming changes?

Not seeing much in the error log only some complaint about external javadocs:

2011-11-28 11:15:59,052 [ 213982]  ERROR - ij.components.ComponentManager - Not disposed pointer: listener=null
url=file://C:/Java/hibernate-distribution-3.5.6-final/documentation/javadocs
Creation trace null

java.lang.RuntimeException: Not disposed pointer: listener=null
url=file://C:/Java/hibernate-distribution-3.5.6-final/documentation/javadocs
Creation trace null

Can't see that being relveant. I've been able to checkout another project from the same repository and incoming changes works for that, but not the main project? One thing that did bother me is the repo path for the project has a space in it. i.e. Project%20Name/Source/... in the intellij log the path appears as Project_Name/Source... whitespace shouldnt be the problem right? (I can't change its repo location).

How can I debug the issue further? Known problems with IDEA 10 svn support?

Running Windows 7 Pro.

- Richard

5 comments

Hello Richard,

- it can either be a problem with a space in repo URL (I will check it here)
- or problem with a big amount of changes. Do you see committed revisions in Repository tab?

0

Yes the repository tab is showing everything I'd expect, including the last couple of days of commits that the incoming tab is missing.

0

Just tried upping the logging level on incoming changes by adding:


  <category name="#incoming">
  <priority value="DEBUG"/>
  <appender-ref ref="INCOMING_CHANGES_FILE"/>
  </category>


to log.xml. Not sure I'm seeing anything unusal, no obvious errors at least. I know our build.xml file has changed a couple of times over the weekend, the incoming.log shows:


2011-11-28 13:54:28,798 [   5179]   INFO - i.vcs.changes.ChangeListWorker - [addChangeToList] name: Default change: C:/Projects/Navigator_trunk/build.xml vcs: null
...
2011-11-28 13:55:49,903 [  86284]  DEBUG -                      #incoming - C:\Navigator Product\trunk\Source\build.xml (33181): Modified -> true [Skipped] 101
...


Not sure what [Skipped] 101 means? but note the path is reported as  "C:\Navigator Product\trunk\Source\build.xml" in the second line above. This is wrong as the project is clearly checked out to: "C:\Projects\Navigator_trunk" as shown by the previous logging line..?

0

I've managed to replicate the issue over the weekend by installing VisualSVN Server (2.5.1) onto my Windows 7 laptop and creating a repository and a project under that repository with spaces in the project name. IntelliJ can view the history via the repository tab. But incoming changes are't being shown for the project with whitepace somewhere in its name or parent path. Other projects without whitespace appear to work fine and can see incoming changes as normal. This Windows/VisualSVN setup duplicates the company repoistory pretty well, although its running an older version of VisualSVN looks like I'm seeing the same issue on the current version.

Eclipse/Subversive also seems to be working and showing incoming changes on the same project(s) in the same repository, seems to be perfectly valid to have whitespace in project names.

I've also tried latest IntelliJ 11 EAP and the same SVN issue persists, even if I created a completely new profile ignoring my IDEA 10 configuration. Tried clearing the VCSCache so many times its not funny. Has anybody else noticed this problem? Can they suggest a workaround that doesn't mean a tricky to schedule and distribtive project name change for 20+ developers all on Eclipse, just beacuse my singular copy of IDEA isn't working?

0

Please sign in to leave a comment.