Flex Debugger hangs when modifying breakpoints while debugging on Linux

I am currently running IntelliJ IDEA 10.5.2 Build 107.587 on Ubuntu 10.04 LTS.  I am running the Flash Debug Player (both versions 11.1 and 10.3) on my various browsers (Internet Explorer 9, Chrome 15.0.874, Firefox 7.0.1) .  I have tried debugging against a remote browser session and a local browser session.  In all cases, debugging runs correctly until I add or remove a breakpoint.  Then, the application hangs and my debugger stops working.  I have to kill the process and close my browser to get things working again.

I have searched this issue on this forum and on Google, and I cannot find anyone who is having the same problem.  Has anyone experienced this issue?  Is there a problem with my configuration?

9 comments
Comment actions Permalink

By killing the process you mean clicking 'Stop' button in debugger tool window, right?
I'm afraid the bug is in Flash Player for Linux. As you know Linux has the least priority for Adobe. So far I don't know workarounds. Was debugging working correctly with any other Flash Player version?

0
Comment actions Permalink

Yes, I kill the process by selecting the "Stop" button in the debugger window.  I have noticed that Flash Player is buggy on Linux.  I first ran into an issue where the debug session was radomly terminated with the message "Player session terminated" when debugging an application running in Flash Player (version 11 on both Chrome and Firefox) on Linux.  I found several posts about this issue and abandoned debugging on Linux altogether.  I then started to debug remotely against various Flash Player instances (versions 11 and 10.3) running in various browsers (IE9, Chrome, and Firefox) on multiple Windows machines (Windows 7 and Windows Server 2008).  The session connects and I no longer get the "Player session terminated" issue.  However, I do have the problem in all cases (no matter the Windows platform, browser, or the version of the Flash Player) where if I add or remove a breakpoint in IntelliJ (running on my Linux server) while the debugger is connected to my remote Flash Player instance, the debugger hangs and I have to stop the debugger.  The only way to recover is to restart the debugger and reinitialize the application.  So, remote debugging seems to work fine until I modify the breakpoints.  I need this type of debugging to work because I often modify the breakpoints while I debug (I assume this is not uncommon).  I am running IntelliJ in a Linux environment because the server tier of the application is built on and runs on Linux and development is faster and easier for me if they are all in the same place.  I am going to try older versions of the Flash Player to see if I run into the same issue.  Do you have any other suggestions?  Could this be an IntelliJ on Linux bug?

0
Comment actions Permalink

Actually, in order to kill the process, I cannot just click the "Stop" button.  I actually have to click the "Close" button and select the checkbox for "Terminate the process after disconnect."  Then, I can start over.  Also, I tested with Flash Debug Player 10.1 (the minimum required to support our application), and I still have the same problem (adding or removing breakpoints hangs the debugger and the application).

0
Comment actions Permalink

Sometimes I even have to close IntelliJ entirely to regain access to the application which freezes the browser.

Alexander, I found a defect that you commented on that is probably related to this issue (http://youtrack.jetbrains.net/issue/IDEA-57546).  I am actually putting a breakpoint in a DataGrid extension AS class though, but itemRenderers could be involved.  However, the fix it mentions (idea-fdb-3-fix.jar) is in place as far as I can tell from the debug command line:

/usr/lib/jvm/java-6-sun-1.6.0.26/jre/bin/java -Dapplication.home=/home/aaluth/FlexCommons-sdks/2.5 -Xmx384m -Dsun.io.useCanonCaches=false -Djava.awt.headless=true -Duser.language=en -Duser.region=en -Xmx512m -classpath /home/aaluth/Downloads/idea-IU-107.587/plugins/flex/lib/idea-fdb-3-fix.jar:/home/aaluth/FlexCommons-sdks/2.5/lib/fdb.jar flex.tools.debugger.cli.DebugCLI

The only other thing that I can think of is that there is a problem with the sdk I am using.  My company has forked the 3.2 SDK, and this may be causing the inconsistency.  I will try debugging with an unforked 3.2 SDK and see if I have the same issue.

0
Comment actions Permalink

I modified to debug using the official Flex 3.2 SDK and I have the same problem.

0
Comment actions Permalink

I have attached the logs after adding the following to log.xml (as suggested in your comments on previous issues):

<log4j:configuration>
<category name="com.intellij.lang.javascript.flex.debug">
<priority value="DEBUG"/>
</category>
...


I have confirmed that when I get into this state, I have to close IntelliJ (just stopping or terminating the process keeps the application locked and hung in the browser).

It appears to send "break" on the line that I added a breakpoint and then the browser is hung.  IntelliJ is not hung, however.

Hope all of this helps narrow down the issue.



Attachment(s):
idea.log.zip
0
Comment actions Permalink

So far I have no idea what's going wrong. May be somehow reated to your local network. Please try to use debugger from some more recent Flex SDK (e.g. just released 4.6). Note that you don't have to change SDK set for the module. In Flex run configuration there's field 'Use debugger from SDK'. So you can keep patched 3.2 for compilation/highlighting, but use debugger from 4.6.

0
Comment actions Permalink

I guess it could be a network issue, but debugging is working fine (hitting breakpoints and everything) before I make modifications to breakpoints.  Also, something must be sent to the remote player when I set a breakpoint because it is causing it to hang (at least it is not ignoring the breakpoint modification completely, which would suggest a network issue, maybe.

I tried your suggestion (downloading the latest Flex SDK 4.6 and using that as my debug SDK.  Unfortunately, I have the same exact issue.

Thanks.

0
Comment actions Permalink

I installed IntelliJ on my Windows box and loaded my project from my Linux box.  When debugging in this environment, I do not have the problem.  I will just debug this way until there is a solution, if one is found.  Thanks for investigating.

0

Please sign in to leave a comment.