Auto-completion and JavaDoc

Hi all,

I have a couple of issues with JavaDoc in IntelliJ 10.5.

1) Most importantly, I don't see any documentation in the popup that should show it. If I press CTRL+Space and I narrow down the possibilities to one function (and or click CTRL+Q) I see its signiture and next to that box I see the JavaDoc popup which only says "Documentation for method()" and nothing else. If I click on the pin in top right corner, I get a big window with the actual JavaDoc.

2) If the function is my custom function inside of the same file with simple JavaDoc (just the general method description) then the big JavaDoc window is just a gray empty box (just a rectangle on top of everything) or it only shows the type and name of the method.

3) JavaDoc only shows when I trigger autocompletion by pressing CTRL+Space (I read somewhere that this the behavior and I'd strongly support such a feature request).

Additionally, the behavior of the JavaDoc window is just weird, the pinned JavaDoc window sometimes disappears, turns into the gray box or turns into the popup again.


Being able to easily see the JavaDocs is probably the number one feature of an IDE for me and I am really sad that it is so buggy in IntelliJ which I really like in other areas :(


Last but not least, I am using the Windows version on Windows 7.


Thank you for any suggestion to solving these problems.

Mike

5 comments

Hi Michal,

Can I ask you to provide more details about the problem - tried to reproduce it loclaly but with no luck - http://dl.dropbox.com/u/1648086/video/completion.avi

Denis

0

Hi Denis,

after reading your reply I got an idea of what might have been the cause of problems and indeed it is so.

Fortunately for you, unfortunately for me, it is the visual style I am currently using in Windows 7. Such an issue can be usually solved by ticking "Disable visual themes" in the properties of a Windows shortcut. That doesn't seem to have any effect on IntelliJ though :(. If I switch to default visual style, I get the correct behaviour. Switching the "Look and Feel" of IntelliJ has no effect on the issue either.

I can still try to provide you with a capturing of the issue but it is probably not worth for you since this is more of an issue of the visual style rather than the IDE.

If interested, I am using the Ashtray Bordeless version of this style: http://browse.deviantart.com/customization/skins/windows7/visualstyle/?order=9#/d346dad

Any suggestion how I could get around this? I can't think of anything else but to switch the style off completely.

Cheers,

Mike

P.S.: I've attached comparison screenshot of the situation using the different visual styles



Attachment(s):
intellijjavadocbug.png
0

Hi Michal,

Your screenshot allows to assume that you can manually expand the javadoc popup, i.e. drag its bottom-right corner by mouse and move. Is it possible?

I'll also ask our GUI guys to have a look at this thread.

Denis

0

Btw, can you try v.11 beta and check if it has the same problem as 10.5 at your environment?

Denis

0

It is not possible to resize the box in 10.5 (it disappears).

The good news is, version 11 works fine!!! :)

The only remaining issue I am having now is that if I switch to a different application while having the autocompletion box (the one with options, not javadoc) showing, it stays "always on top", visible over the other application (or any other I switch to). And the only way to get rid of it is to go back to IntelliJ and let it disappear...

Self-explanatory screenshot provided.

Cheers,

Mike



Attachment(s):
intellijcompletionbug.png
0

Please sign in to leave a comment.