How to prevent IntelliJ IDEA from importing "*"?

(IntelliJ IDEA newbie here; you have been warned).

It seems like after a few imports like

    import a.b.c1;
    import a.b.c2;
    import a.b.c3;
    ...

IDEA decides it knows better than you and changes what you typed to

    import a.b.*;

If that's what I wanted, that's what I would have typed, TYVM.  Is there
any way to disable this (to me) enragingly annoying "feature"??

Thanks in advance!

1 comment
Comment actions Permalink

Hi Julian,

Please check 'Class count to use import with '*'' option. However, more convenient approach is to avoid explicitly typed imports because the IDE allows to do that in semi-automatical way. Feel free to check this page for the detailed information.

Denis

0

Please sign in to leave a comment.