-proc:none is ignored Urgent!!!!!!

Hi

I was updating my intellij version from 9 to 10 and now I'm stucked because the -proc:none is ingored by the ide compiler... I'm stucked

3 comments
Comment actions Permalink

Can you clarify the problem and provide a project that reproduces it?

0
Comment actions Permalink

I'm working in 100% maven project that have defined plugins to create sources, and works fine with  9.x Intellij putting -proc:none on compiler arguments... but I'm update my version  to 10.5.  seems that this release ignore this argument, or maybe have a different way to process annotation processing... I resolved the problem enabling annotation processing and setting processor path option with path empty

forget my english

0
Comment actions Permalink

Francisco,
There are 2 cases:

1. Annotation processing options in compiler settings are explicitly enabled and set up. Then the "-proc:none" is implicitly added to javac's argumets no matter whether is it specified in UI or not
2. Annotation processing options in compiler settings are _disabled_. Then no implicit "-proc:none" option is added to javac's command line. That means that this option will be passed to javac only if you specify it explicitly in UI. If you do, the option's effect is to disable annotation processing with autodiscovered processors from the classpath. Note also that this is solely javac who interprets the option; IDEA's job is only to pass it to its command line.

0

Please sign in to leave a comment.