Does anybody encounter unused symbols highlitning problem with 10.5.2?

Hello, Everybody.
For several months (at least form 10.5) i have problems with highlithing. Highlitning doesn't work for unused local varialbles, method parameters, private methods, etc. This is a very sierious functionality loss. I detected this because of my colleague reviewed my code in Eclipse. Is my case unique or somebody else has the same problem?
For example i typed new method and i see it's reported as used:
highlitning_doesnt_work.PNG

No errors observed in log files

And one more picture with local vars and params:
highlitning_doesnt_work_2.PNG

regards, Alex

Message was edited by: Alexander Ashitkin

2 comments
Comment actions Permalink

Hi.

AFAIK, this inspection does not guarantee that not highlighted items are used. It guarantees that highlighted items are not used. If calculations for an item seem to be "too expensive", they are just skipped, and the item stays not reported.

The cases in your pictures look simple enough to make inspection work, but maybe your project has some string entries same to the class/variable name. Trying to guess: do you have same named class (variable) in another module, maybe not dependent? Or just substrings in text files?

(Another necessary-to-ask question: are you sure that all options are On in Unused symbol inspection settings?)

Regards,
Alexander.

0
Comment actions Permalink

Hi, Alexander.
Thank you for response, but reasons you stated above don't look valid. I don't understand why it's necessary to lookup parmeters/local variables in other files. even for private metods  it's very questinable. if you use reflection, you use it on your own risk and violate class contract. So i don't see any reasons to treat it as valid behaviour. It's a very serious functionality regression brought with 10.5.

I tried latest eap and found suspicious entries in the event log:

17:57:29. IllegalArgumentException: Argument 0 for @NotNull parameter of com/intellij/openapi/editor/highlighter/EditorHighlighterFactoryImpl.createEditorHighlighter must not be null: Argument 0 for @NotNull parameter of com/intellij/openapi/editor/highlighter/EditorHighlighterFactoryImpl.createEditorHighlighter must not be null
18:06:21. IllegalArgumentException: Argument 0 for @NotNull parameter of com/intellij/openapi/editor/highlighter/EditorHighlighterFactoryImpl.createEditorHighlighter must not be null: Argument 0 for @NotNull parameter of com/intellij/openapi/editor/highlighter/EditorHighlighterFactoryImpl.createEditorHighlighter must not be null
18:06:52. IllegalArgumentException: Argument 0 for @NotNull parameter of com/intellij/openapi/editor/highlighter/EditorHighlighterFactoryImpl.createEditorHighlighter must not be null: Argument 0 for @NotNull parameter of com/intellij/openapi/editor/highlighter/EditorHighlighterFactoryImpl.createEditorHighlighter must not be null


So i fired bug http://youtrack.jetbrains.net/issue/IDEA-74615

regards, Alex

Message was edited by: Alexander Ashitkin

0

Please sign in to leave a comment.