HTML Pretty Printing

While IDEA has gotten much better at cleaning up JSP/HTML code, it seems to break everytime I empty the "Do not indent children of:" tags list.

I personally wish to have my HTML and BODY tags properly indented as would be a XML file. When I remove these values from the "Do not indent children of" area, pages do not consistently get formatted.

Also, it would be nice to be able to turn off wrapping completely for HTML pages. Sometimes having "Wrap Attributes:" set to "Do not wrap", the page still manages to wrap things.

Finally, if I have a

]]>


I do expect it to be broken out into

  
  

  
  ...
]]>


Any help in this area would be greatly appreciated.

Please sign in to leave a comment.