Building and running IntelliJ from source

I just built Community Edition from source (just ran ant from top level directory and it worked flawlessly). It created a .zip file in out/artifacts which I extracted, then I ran idea.bat.
  It seemed to run pretty smoothly, but I noticed that I didn't have a few of my settings and plugins. When I checked if it had found my IntelliJ settings directory in my home directory, I found it was using the folder '.null' instead of '.IntelliJ10'. I tried changing the line (line 67)
system_selector: "IntelliJIdeaCE${p("component.version.major")}",

in build/scripts/dist.gant  to
system_selector: "IntelliJIdea10",

and recompiled, but no luck!  It's still using '.null'


How can I fix this ?

3 comments
Comment actions Permalink

Intellij has a property file located in the same directory as the idea.exe/.sh file.
idea.properties


it should have lines similar to the following:
# path to IDEA config folder. Make sure you're using forward slashes
idea.config.path=${user.home}/.IntelliJIdea10/config

# path to IDEA system folder. Make sure you're using forward slashes
idea.system.path=${user.home}/.IntelliJIdea10/system

# path to user installed plugins folder. Make sure you're using forward slashes
idea.plugins.path=${user.home}/.IntelliJIdea10/config/plugins

Just points these to the correct path and it should work.

To be safe though if you are using the UI 10.X and IDEA community trunk 11.X then use a seperate directory, perhaps copying over the plugins you need to the newly copied directory.

0
Comment actions Permalink

What do you have in a line 34 of idea.bat?
There should be something starting with "set REQUIRED_IDEA_JVM_ARGS".

0
Comment actions Permalink

Thanks Rob, that was it. (That line was there, Roman)

Thanks for the help guys.

0

Please sign in to leave a comment.