Why was the slash '/' disabled in live templates abbreviation names.

I had several live templates that start with a /(in the abbreviation name), that no longer work in IDEA; plus I cannot even edit them.

Any reason why this was changed? I used them a lot, now I am stranded because someone up and changed what was or was not allowed in a live template abbreviation.

3 comments
Comment actions Permalink

We have prohibited non-identifier abbreviations, cause these make extermely
difficult to find abbreviation in the editor for activating template (yes,
there were such bugs in all prior versions)
Please invent some alphanumeric abbreviation.

Eugene.

"zmbs" <no_mail@jetbrains.com> wrote in message
news:10593454.1124262080291.JavaMail.itn@is.intellij.net...
>I had several live templates that start with a /(in the abbreviation name),
>that no longer work in IDEA; plus I cannot even edit them.
>

Any reason why this was changed? I used them a lot, now I am stranded
because someone up and changed what was or was not allowed in a live
template abbreviation.



0
Comment actions Permalink

Well, I don't want alphanumeric, since they would not flow well.

For example(a simple one), when I insert a //TODO, I just type /t and then tab. Simple. It makes sense and flows well. I use the / for allow comment related templates.

Now, again, I have to change my work flow to fit this application.

I am sorry, but I find it highly annoying, especially after the change was made after the fact and disabled something that previously worked.

Yes, I know, I know, it's not a bug, it's a feature.

0
Comment actions Permalink

zmbs wrote:

Well, I don't want alphanumeric, since they would not flow well.

For example(a simple one), when I insert a //TODO, I just type /t and then tab. Simple. It makes sense and flows well. I use the / for allow comment related templates.

Now, again, I have to change my work flow to fit this application.

I am sorry, but I find it highly annoying, especially after the change was made after the fact and disabled something that previously worked.

Yes, I know, I know, it's not a bug, it's a feature.


You should file an issue at http://jetbrains.net/jira. I think it sounds like a
good idea to fix this.

0

Please sign in to leave a comment.