No anti-aliased editor fonts...

Is it me or does the 5.0.1 RC -not- do AA fonts?

This is under linux (jdk 1.6). IDEA 5.0 does AA fine, but not 5.0.1RC...

14 comments
Comment actions Permalink

Hello Mark,

Is it me or does the 5.0.1 RC -not- do AA fonts?

This is under linux (jdk 1.6). IDEA 5.0 does AA fine, but not
5.0.1RC...


Looks like it's disabled now when IDEA is running under 1.6.

--
Serge Baranov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0
Comment actions Permalink

Serge Baranov wrote on 08/11/2005 11:25 PM:

Looks like it's disabled now when IDEA is running under 1.6.


Doh. AA was the only reason I was actually running IDEA under 1.6 in
the first place ;)

OH well, good to know anyway..

0
Comment actions Permalink

Hello Mark,

Serge Baranov wrote on 08/11/2005 11:25 PM:

>> Looks like it's disabled now when IDEA is running under 1.6.
>>

Doh. AA was the only reason I was actually running IDEA under 1.6 in
the first place ;)

OH well, good to know anyway..


Under 1.6 IDEA used the same AA settings as on 1.5 (no subpixel AA).

--
Serge Baranov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0
Comment actions Permalink

But why?
Is there any hope that it will be enabled?


BoD

Serge Baranov wrote:

Hello Mark,

>> Serge Baranov wrote on 08/11/2005 11:25 PM:
>>
>>> Looks like it's disabled now when IDEA is running under 1.6.
>>>
>> Doh. AA was the only reason I was actually running IDEA under 1.6 in
>> the first place ;)
>>
>> OH well, good to know anyway..


Under 1.6 IDEA used the same AA settings as on 1.5 (no subpixel AA).

--
Serge Baranov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

0
Comment actions Permalink

Hello BoD,

But why?
Is there any hope that it will be enabled?
BoD


I guess because using subpixel AA requires:

a) a special control where you can choose your LCD type
b) code setting AA mode which will only compile and run under 1.6, this will
break our build system and will not run on 1.4 and 1.5.

I think it's possible to find a workaround for b) but our developers have
other more important things to do.

--
Serge Baranov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0
Comment actions Permalink

Ah I see...
Well too bad :) I guess I'll be patient until 1.6 is released.

BoD

Serge Baranov wrote:

Hello BoD,

>> But why?
>> Is there any hope that it will be enabled?
>> BoD
>>


I guess because using subpixel AA requires:

a) a special control where you can choose your LCD type
b) code setting AA mode which will only compile and run under 1.6, this
will break our build system and will not run on 1.4 and 1.5.

I think it's possible to find a workaround for b) but our developers
have other more important things to do.

--
Serge Baranov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

0
Comment actions Permalink

OK, but it works just fine with IDEA 5.0.

Something must have been changed to stop it working with 5.0.1.

0
Comment actions Permalink

Are you saying you have sub-pixel AA working on IDEA 5? If so, how did you setup 1.6 JRE to work with IDEA?

0
Comment actions Permalink

Hello Mark,

MD> Is it me or does the 5.0.1 RC -not- do AA fonts?
MD>
MD> This is under linux (jdk 1.6). IDEA 5.0 does AA fine, but not
MD> 5.0.1RC...

We reverted the change to AA settings done between 5.0 and 5.0.1RC, so the
final 5.0.1 will work exactly the same as 5.0. Note that we still don't officially
support anything related to jdk 1.6, so - use at your own risk. :)

--
Dmitry Jemerov
Software Developer
JetBrains, Inc.
http://www.jetbrains.com
"Develop with pleasure!"


0
Comment actions Permalink

Hello Mark,

OK, but it works just fine with IDEA 5.0.

Something must have been changed to stop it working with 5.0.1.


Again, simple AA worked in 5.0, not subpixel. Maxim disabled the code enabling
simple AA when IDEA is under 1.6 for some reason. Probably he thought that
it will enable subpixel AA automatically, but it doesn't work. Maxim is on
the vacation now, so I doubt that this will be changed soon.

--
Serge Baranov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0
Comment actions Permalink

Yes, the original poster was talking about simple AA no longer working and that's what I was posting about too.

This is what we're not happy with:

>Maxim disabled the code enabling simple AA when
>IDEA is under 1.6 for some reason

As long as it comes back eventually I'll be happy. It really does make a big improvement to the display.

Thanks!

0
Comment actions Permalink

I guess I should have noticed Dimitry's reply before I posted the above - seems it's no longer an issue.

Thanks again!

0
Comment actions Permalink

Dmitry Jemerov (JetBrains) wrote on 08/13/2005 12:11 AM:

We reverted the change to AA settings done between 5.0 and 5.0.1RC, so
the final 5.0.1 will work exactly the same as 5.0. Note that we still


Cheers :)

don't officially support anything related to jdk 1.6, so - use at your
own risk. :)


Understood :)

0
Comment actions Permalink

Hello Mark,

MD> Is it me or does the 5.0.1 RC -not- do AA fonts?
MD>
MD> This is under linux (jdk 1.6). IDEA 5.0 does AA fine, but not
MD> 5.0.1RC...

And even better news: when running under Mustang build 47 or later, IDEA
5.0.1 will use the system antialiasing settings (including support for LCD
text antialiasing, AKA ClearType) when drawing text in the editor.

--
Dmitry Jemerov
Software Developer
JetBrains, Inc.
http://www.jetbrains.com
"Develop with pleasure!"


0

Please sign in to leave a comment.