Change variable / return type idea

I use generics frequently. Lately, when I want to change the method return type
to some long type, I've been changing method return types to void, just to get
the red underline and "change type" intention, so I don't have to type that long
type name.

I suggest simply showing the "Change type" intention whenever the LHS or return
type could be changed to the given type. What do you guys think?

However, I think this would annoy me in cases like List x = new ArrayList]]>();. Maybe there should be some way to exclude classes, or maybe
this feature idea sucks.

Please sign in to leave a comment.