sync block code formatting

When I enter a synchronize statement I end up with it layed out like:

rather than:


Is this a bug, or am I missing the proper configuration option?

even though I have braces placement/other set to 'next line'. It works fine in other contexts like 'if' or 'static'.

3 comments
Comment actions Permalink

I just tried this with the release version of 5.0 and don't have this problem. Either you have something screwed up in your project code style settings or you have some kind of coding error that's throwing the parsing off.

0
Comment actions Permalink

Broken in 3431, fixed in 3436.

0
Comment actions Permalink

Fixed: 3436
Code style doesn't work for synchronized statement
http://www.jetbrains.net/jira/browse/IDEADEV-2163

0

Please sign in to leave a comment.