IntelliJ Encoding? Windows XP to 7 problem?

I've been working on a project on Windows XP with IntelliJ 10.5.1. I 7-zip the project, unzip it and open it with IntelliJ 10.5.1 and all the sudden it can't resolve any of the classes. They all have the little 'j' icon on them. As soon as I open them up it seems to parse and index it. What has happened? I really don't want to go through hundreds of files opening them up just so that IntelliJ can re-save them in some format.

I've never touched the encoding settings. So, what should I do?

Thanks,
Michael

2 comments
Comment actions Permalink

I doubt that it's an encoding problem.
This should help:
    File -> Invalidate Caches


On 17.08.2011 04:35, Michael Newcomb wrote:

I've been working on a project on Windows XP with IntelliJ 10.5.1. I 7-zip the project, unzip it and open it with IntelliJ 10.5.1 and all the sudden it can't resolve any of the classes. They all have the little 'j' icon on them. As soon as I open them up it seems to parse and index it. What has happened? I really don't want to go through hundreds of files opening them up just so that IntelliJ can re-save them in some format.

>

I've never touched the encoding settings. So, what should I do?

>

Thanks,
Michael

>

---
Original message URL: http://devnet.jetbrains.net/message/5316959#5316959


0
Comment actions Permalink

For some reason the project was set for UTF-8. I reset it back to <System Default> but still had a problem compiling ("unmappable character ... utf8").

I eventually deleted the .intellij cache directory and it seemed to go back to normal.

Thanks for the tip about the invalidate cache, that might have been all that was required in the first place!

0

Please sign in to leave a comment.