3429 - Taglibs (tlds) no longer resolve for relative URIs in JSPs

If a taglib definition is defined in a JSP like so:
<%@ taglib prefix="html" uri="/WEB-INF/struts-html.tld" %>

and if an External resource is configured for this uri,
The taglib no longer resolves (leaving red errors all over the page)

Inspection Error message:
"Cannot resolve taglib with uri /WEB-INF/struts-html.tld"

The exteranl resource is configured correctly (as the same resource configuration works fine with IntelliJ 4.5.3 side by side.

9 comments
Comment actions Permalink

Could not reproduce with jsp/tld in webmodule.
Please, provide more details/sample code in JIRA request.

Paul Wilton wrote:

If a taglib definition is defined in a JSP like so:
<%@ taglib prefix="html" uri="/WEB-INF/struts-html.tld" %>

and if an External resource is configured for this uri,
The taglib no longer resolves (leaving red errors all over the page)

Inspection Error message:
"Cannot resolve taglib with uri /WEB-INF/struts-html.tld"

The exteranl resource is configured correctly (as the same resource configuration works fine with IntelliJ 4.5.3 side by side.



--
Best regards,
Maxim Mossienko
IntelliJ Labs / JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

0
Comment actions Permalink

which Jira project do I create a request on - I have registered but when I create a new issue, there doesnt seem to be an option for IntelliJ 5/Irida?

0
Comment actions Permalink

same at my environment. Exactly the same setting in 4.5.3 taglibs are resolved. In 5.0 - "cannot reolve taglib"

0
Comment actions Permalink

I dont seem to be able to make a Jira request on Intellij.

The code however is exactly how I posted in the first post on this thread:

Line 1 of JSP:
<%@ taglib prefix="html" uri="/WEB-INF/struts-html.tld" %>

The configure an external resource to point to this RELATIVE URL.
However, IntelliJ does not resolve the resource to the tld on my local disk as specified in the external resources config.

(note absolute URLs work, Relative URLs dont)

0
Comment actions Permalink

note - I am not using a web module (whatever that is :o)
just a normal project?

0
Comment actions Permalink

Jumped the gun a bit :o)
This bug is fixed in build 3431
Good work!

0
Comment actions Permalink

In article <13753207.1122841672636.JavaMail.javamailuser@localhost>,
Paul Wilton <no_mail@jetbrains.com> wrote:

note - I am not using a web module (whatever that is :o)
just a normal project?


? How are you not using a webmodule and expect to work with jsps in idea?

R

0
Comment actions Permalink

Relative pathes to jsps, absolute references (URI) to taglibs

Robert S. Sfeir wrote:

In article <13753207.1122841672636.JavaMail.javamailuser@localhost>,
Paul Wilton <no_mail@jetbrains.com> wrote:

>>note - I am not using a web module (whatever that is :o)
>>just a normal project?


? How are you not using a webmodule and expect to work with jsps in idea?

R



--
Best regards,
Maxim Mossienko
IntelliJ Labs / JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

0
Comment actions Permalink

Relative pathes to jsps, absolute references (URI) to taglibs


But he also loses everything else which he gets with a web app. And he
did say something to the effect of 'what ever the heck that is'
(regarding a web module), so perhaps the user is not aware of what he
could be getting.

R

0

Please sign in to leave a comment.