Problem with gsp files. Idea 10.5.1 Community Edition.

Hello everybody!

I have problem with gsp files in  Idea 10.5.1 Community Edition.

I created simple application with grails and opened it in Idea.

When *.gsp pattern added to groovy files types there is error:
unexpected token: < @ line 1, column 1.    <html>

When *.gsp pattern added to jsp files types everything is ok, but it
seems that I lost code completion support in this case.

I tested gsp in Ultimate edition and everyting seems work fine...

So what I'm doing wrong? Maybe I wrongly configured grails and groovy?

Thanks in advance.

1 comment
Comment actions Permalink

Hello Anton,

IntelliJ IDEA Community Edition does not include support for Grails. GSP
pages are a separate file type in IntelliJ IDEA Ultimate; these are not Groovy
files.

Hello everybody!

I have problem with gsp files in  Idea 10.5.1 Community Edition.

I created simple application with grails and opened it in Idea.

When *.gsp pattern added to groovy files types there is error:
unexpected token: < @ line 1, column 1.    <html>
When *.gsp pattern added to jsp files types everything is ok, but it
seems that I lost code completion support in this case.

I tested gsp in Ultimate edition and everyting seems work fine...

So what I'm doing wrong? Maybe I wrongly configured grails and groovy?

Thanks in advance.


--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0

Please sign in to leave a comment.