Problem starting Tomcat 7.0.19

I'm new to Java, and while learning I've decided to use InteliJ IDEA for it.
I have experience with the IDE through PHP development.
I've used this wiki to setup a test project:
http://wiki.jetbrains.net/intellij/Creating_a_simple_Web_application_and_deploying_it_to_Tomcat

I'm having a problems with the server



This is what I get in the output window when i try to run index.jsp


cmd /c "C:\Program Files\Java\jdk1.6.0_26\bin\java" -Dcatalina.base=C:\Users\Ivx\.IntelliJIdea10\system\tomcat\_jsp_TEST -Dcatalina.home=C:\Tomcat -Djava.io.tmpdir=C:\Tomcat\temp -cp C:\Tomcat\bin\bootstrap.jar;C:\Tomcat\bin\tomcat-juli.jar org.apache.catalina.startup.Bootstrap start
java.lang.NoClassDefFoundError: org/apache/juli/logging/LogFactory
 at org.apache.catalina.startup.Bootstrap.<clinit>(Bootstrap.java:60)
Caused by: java.lang.ClassNotFoundException: org.apache.juli.logging.LogFactory
 at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
 at java.security.AccessController.doPrivileged(Native Method)
 at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
 at sun.misc.Launcher$ExtClassLoader.findClass(Launcher.java:229)
 at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
 at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
 ... 1 more
Could not find the main class: org.apache.catalina.startup.Bootstrap.  Program will exit.
Exception in thread "main" Disconnected from server


Am I doing something wrong?

3 comments
Comment actions Permalink

Also, Tomcat server is running fine outside the Idea IDE.

0
Comment actions Permalink

Are you sure that Tomcat is installed properly? Do you have 'catalina.bat' and 'tomcat-juli.jar' files in 'c:\tomcat' directory?

--
Nikolay Chashnikov
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

0
Comment actions Permalink

Hi, I had a problem with Java 7, now everything is working correctly.
IDE wasn't the problem.
Thank you for your feedback.

0

Please sign in to leave a comment.