"Check out from CVS repository" really slow, causes Irida 3394 to hang...

I'd like to check out the SwingX project from CVS on "java.net", but the "Check out from CVS repository" dialog isn't able to help me...

On the page:
https://swingx.dev.java.net/servlets/ProjectSource

...the instructions (for registered users) indicate that I should go for the "swingx" module of:

:pserver:username@cvs.dev.java.net:/cvs

...but this isn't working. Specifically, when choosing the option to checkout a new project from CVS from IDEA's welcome screen, I can specify the new CVS server using the above parameters (and successfully test the connection), and then I need to go onto the second dialog in the IDEA wizard ("select cvs elements to check out"). It displays a tree with the root element being the cvs repository name, and a branch "loading"... and just hangs.

I waited 20 minutes with no results. Clicking "cancel" closed the dialog box, and left me with an unresponsive grey IDEA main window. Is it a bug or have I missed something?

In any case, using an Eclipse-2.1-based-WSAD-5.0 CVS explorer, I had to wait a short time (there's a LOT of modules), but it got them and I was able to check out the project that interested me. I then copied these files to a new folder, set it up as an IDEA project, told it I was using CVS (without needing to specify any parameters), and it worked. I can for example correctly access the CVS history on the files.

4 comments
Comment actions Permalink

The CVS support in IDEA has one major drawback. If anything goes wrong, it hangs. This makes debugging the problem extremely tricky.

This issue is probably the only serious issue that I have with IDEA and it just drives me nuts.

Donald

0
Comment actions Permalink

It's still really really slow. IDEA 5.0 RC1 seems to hang consistently.

0
Comment actions Permalink

Christopher Brown wrote:

It's still really really slow. IDEA 5.0 RC1 seems to hang consistently.


File a JIRA issue for it. Somewhere in this forum is a post describing
how to turn on debug information for the CVS plugin. If you can find
that, that might also be useful information to put in the JIRA issue.

Ciao,
Gordon

--
Gordon Tyler (Software Developer)
Quest Software <http://www.quest.com/>
260 King Street East, Toronto, Ontario M5A 4L5, Canada
Voice: (416) 933-5046 | Fax: (416) 933-5001

0
Comment actions Permalink

OK, with 3417, it took ages, but worked.

Please ensure that the user interface doesn't "freeze" during this operation. If modality is important, perhaps you could show a dialog box. If not, in the "CVS - browse" tool window, under the tree's root node (for the repository), where it currently shows "Loading...", maybe update it to show "Loading... 123 modules(s) found so far..." and keep the UI "alive".

Eclipse has a good reputation for its CVS integration, it'd be worth a "little" usability improvement like this to keep the impression of speed and stability with IntelliJ IDEA.

0

Please sign in to leave a comment.