Is autocomplete in 10.5 driving you crazy?

I know its driving me crazy. The suggestion popup list used to be almost magical in its ability to present the exact class I wanted, thus saving me a nice bit of typing. Now, I get an endless list of classes that have NOTHING to do with what the current context.

For instance, I just typed  'Str' and the first entry listed and selected is SAXTransformerFactory, followed by SQLTransactionRollbackException.

Is there some magic to getting things back to pre-10.5 operation?

3 comments
Comment actions Permalink

I managed to make things a little better by tweaking the settings in Editor | Code Completion.

Specifically:

-  I unchecked all options under 'Autocomplete when only one choice'
-  Set 'Autopopup code completion in (ms)'  to something > 0  (300 works for me)

The combination of these two prevented unwanted autocompletions that were occuring in the middle of typing a variable name.

I messed around with all 'Case sensitive completion' options, and couldn't see a difference in the behaviour of the popup.
Perhaps that is not the intent of that configuration item.
(Typing 'Str' -- lowercase 'tr' still was looking for classes with inter caps in combinations of 'S', 'T' and 'R'.)

0
Comment actions Permalink

Sorry for the late response. Have you tried 10.5.1 EAPs? We included some fixes there. Also, completion uses statistics and when you select a wrong item it's moved up in the list the next time. So you may have to select the right String 4-5 times to get the statistics right. Also, please check that you don't have alphabetical sorting on (the letter in the lower right corner of the completion list should be Pi, not A).

0
Comment actions Permalink

Hi Peter,

"Also, please check that you don't have alphabetical sorting on (the  letter in the lower right corner of the completion list should be Pi,  not A)."

BINGO! : I never noticed that 'A'/Pi in the corner. At some point I must have inadventantly clicked it. Things are much better now.

Thanks!

0

Please sign in to leave a comment.