java.lang classes not found for project

I just got a new pc so I set up intellij on the new pc.  It seems like it is set up identical to my old but it does not seem to be able to find the basic java.lang classes.  I have done all of the settings stuff for setting up the sdk, including the project and module SDKs.  In the platform settings screen  I can do maven builds just fine but when I look at files via the editor and when I do individual compiles, it says that these basic java classes cannot be found.    I would appreciate any feedback as to other things I can try.

4 comments
Comment actions Permalink

I messed up one sentence here.  In the platform settings, I can see all of the standard jar files listed so it seems like my setting for the sdk directory is correct.  And then I meant to say also that I can build maven projects just fine from the maven projects pane.  It is just the individual compiles and the syntax checking from the editor that doesn't seem to work.

0
Comment actions Permalink

You're describing what happens when the project JDK is not setup properly.  I would suggest taking another look via File -> Project Structure and clicking Project on the left hand side of the window that comes up.  Make sure a Project SDK is defined and click "Edit" if one is and verify all the paths are correct.

0
Comment actions Permalink

The paths look fine for the SDK that I specified in the project sdk.  I clicked on edit and all of the jar files are listed there from my SDK dir.

0
Comment actions Permalink

Ok, here is what I think are the variables involved.  I am on Windows 7 64-bit, running 32-bit intellij but the
Platform Setting SDK is a 64-bit IBM SDK.  That combination does not appear to work.  I
switched to point to a Sun SDK 64-bit and it finds the java.lang stuff.  I had someone else on my team verify that the
same combination fails for them.  They changed it to use the 32-bit IBM SDK and it was able to find the classes.
We have been trying to make the idea64.exe work but the version that is out there on the web doesn't seem to launch for us.  
Is there a community edition version of the idea64.exe for 10.5?

0

Please sign in to leave a comment.