javascript code style question

Hello,
For the following code intellij puts two tabs for the content passed as an object parameter to the override function.  Is there a way to configure it to only do a single tab?

Ext.selection.CheckboxModel.override({
           /**
            * Overridden function to fix a bug where the suppressEvent parameter was not being respected.
            *
            * Synchronize header checker value as selection changes.
            * @private
            * @override
            */
           onSelectChange: function(record, isSelected, suppressEvent) {
                this.callParent([record, isSelected, suppressEvent]);
                // check to see if all records are selected
                var hdSelectStatus = this.selected.getCount() === this.store.getCount();
                this.toggleUiHeader(hdSelectStatus);
           }
           });

4 comments
Comment actions Permalink

I think this is http://youtrack.jetbrains.net/issue/IDEA-69762
which should be fixed since IDEA 10.5.1 EAP build 107.148,
see http://confluence.jetbrains.net/display/IDEADEV/IDEA10.5EAP

On 15.06.2011 21:10, Gordon Bockus wrote:

Hello,
For the following code intellij puts two tabs for the content passed as an object parameter to the override function.  Is there a way to configure it to only do a single tab?

>

Ext.selection.CheckboxModel.override({
            /**
            

  • Overridden function to fix a bug where the suppressEvent parameter was not being respected.

             *
            

  • Synchronize header checker value as selection changes.

            

  • @private

            

  • @override

             */
            onSelectChange: function(record, isSelected, suppressEvent) {
                 this.callParent();
                 // check to see if all records are selected
                 var hdSelectStatus = this.selected.getCount() === this.store.getCount();
                 this.toggleUiHeader(hdSelectStatus);
            }
            });

>

---
Original message URL: http://devnet.jetbrains.net/message/5306524#5306524


0
Comment actions Permalink

Try changing a continuation indent to 4 spaces if you haven't done so yet. See Settings|Code Style|General|JavaScript|Continuation indent. In later versions it will be 4 spaces by default.

0
Comment actions Permalink

Thanks for the reply.

I did update the continuation indent, but it had other side affects that I were worse then the original problem.  I think that the reply with the update to intellij fixes my problem.  I haven't tried it yet, but it sound correct.

0
Comment actions Permalink

That fix looks like what I'm after.  Thanks

0

Please sign in to leave a comment.