Navigation intermittently broken in Idea X

I'm finding that using the ctl-alt-Left/Right arrows is unreliable in Idea X.  It fairly regularly just stops/gives-up navigating. In order to get back to where I started, I end up using Ctl-N to find the class and then it puts me not in the place I started.

Anything to do here - or need to submit JIRA?

15 comments
Comment actions Permalink

I have found this is happening consistently for certain files.  They are java classes within java modules.  Other java classes in the same module seem to be able to do navigation properly.

So here is what is happening: from CollectionUtils and SharedCollectionsServiceV3ConsumerAPI classes, I can navivate to  other classes in the same or different modules.  But for those particular classes I can never navigate back to them.  I am able to get back to those classes by doing CTL-N (find class).

0
Comment actions Permalink

There used to be (IntelliJ 7.x/8.x) a major problem with navigation when using the IdeaVIM plugin (vi emulator). However, those problems appeared to go away when jetbrains started to maintain that particular plugin.

Are you using IdeaVIM by chance?

0
Comment actions Permalink

Hi,
  thanks for the reply.   No I'm using the default Idea X CE configuration (no additional plugins installed yet).   I am about to re-install with Idea Ultimate today, I doubt will make any difference but let's see.

0
Comment actions Permalink

Navigation is still intermittently broken in X ultimate.


0
Comment actions Permalink

Yes, this is driving me nuts too.  It seems to be related to having multiple editor panes or windows open.  When I use a single editor window, everything works as expected.

0
Comment actions Permalink

Unless I get some answer from JetBrains on this, I'm going to put in a JIRA.  I'll update this with the JIRA (and encourage you to vote on it ).

0
Comment actions Permalink

Yann Cebron has helpfully provided a link to existing JIRA.  

http://youtrack.jetbrains.net/issue/IDEA-22870

I have commented on the JIRA and added my vote.  Suggest you vote there too  ;)

0
Comment actions Permalink

The issue seems to be getting quite a bit of attention, looks promising for a fix in a forthcoming release. But votes are always helpful.

0
Comment actions Permalink

(removed dup message)

0
Comment actions Permalink

Shouldn't a new JIRA be created for this? An existing, closed ticket may only be confusing -- after all Intellij9 did not exhibit this issue.

0
Comment actions Permalink

Upgraded to 10.0.2 -- manual "scroll to" still broken with split panes, history "go back" is still broken with split panes. =/

0
Comment actions Permalink

I am using 10.5 now and so far have not noticed the problem. Let's hope ..

0
Comment actions Permalink

Yea I think it works for me now too -- now try manually scrolling to source using split panes :)

0

Please sign in to leave a comment.