Google App Engine (GAE) Process finished with exit code 139 Mac OS X 10.6.7 64 bit Jdk 1.6

Hi I am trying to start Google App Engine on my Mac OS X

I starts and after a few seconds it Disconnects with

Process finished with exit code 139

I have the Searched the community but none of the suggested soultions works ..

Any Idea  - log files etc to look for ??


Jesper

Here is ALL the stacktrace from the Console

/System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home/bin/java -javaagent:/Users/jesper/lib/appengine-java-sdk-1.4.3/lib/agent/appengine-agent.jar -XstartOnFirstThread -Dfile.encoding=MacRoman -classpath /Users/jesper/lib/appengine-java-sdk-1.4.3/lib/appengine-tools-api.jar com.google.appengine.tools.development.DevAppServerMain -p 8080 --disable_update_check /Users/jesper/IdeaProjects/ConfigIt/out/artifacts/ConfigItBackend_war_exploded
2011-05-13 13:59:02.148 java[5088:903] [Java CocoaComponent compatibility mode]: Enabled
2011-05-13 13:59:02.150 java[5088:903] [Java CocoaComponent compatibility mode]: Setting timeout for SWT to 0.100000
May 13, 2011 11:59:02 AM com.google.apphosting.utils.jetty.JettyLogger info
INFO: Logging to JettyLogger(null) via com.google.apphosting.utils.jetty.JettyLogger
May 13, 2011 11:59:02 AM com.google.apphosting.utils.config.AppEngineWebXmlReader readAppEngineWebXml
INFO: Successfully processed /Users/jesper/IdeaProjects/ConfigIt/out/artifacts/ConfigItBackend_war_exploded/WEB-INF/appengine-web.xml
May 13, 2011 11:59:03 AM com.google.apphosting.utils.config.AbstractConfigXmlReader readConfigXml
INFO: Successfully processed /Users/jesper/IdeaProjects/ConfigIt/out/artifacts/ConfigItBackend_war_exploded/WEB-INF/web.xml
May 13, 2011 11:59:03 AM com.google.apphosting.utils.jetty.JettyLogger info
INFO: jetty-6.1.x
May 13, 2011 11:59:04 AM com.google.apphosting.utils.jetty.JettyLogger info
INFO: Started SelectChannelConnector@127.0.0.1:8080
May 13, 2011 11:59:04 AM com.google.appengine.tools.development.DevAppServerImpl start
INFO: The server is running at http://localhost:8080/
Connected to server
May 13, 2011 11:59:06 AM com.google.appengine.tools.development.LocalResourceFileServlet doGet
WARNING: No file found for: /favicon.ico
Disconnected from server

Process finished with exit code 139

5 comments
Comment actions Permalink

If jvm process was crashed were should be *.log files generated in the output directory of the exploded war artifact specified in App Engine run
configuration.

--
Nikolay Chashnikov
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

0
Comment actions Permalink

I have the same problem. I can verify that there are no logs generated where you suggest.

Also, the app deploys fine on Google App Engine and runs as it should. However, not possible to run it locally.

0
Comment actions Permalink

Someone can resolve this problem?
I use IDEA 10.5 and can`t start Server, he`s  disconnect: "Process finished with exit code 139", I have time send 1 request %(
Need help.  Or i  be need select Eclipse IDE.

 

In debug console:

INFO: The server is running at http://localhost:8080/
Disconnected from the target VM, address: '127.0.0.1:65104', transport: 'socket'
Disconnected from server

Process finished with exit code 139

0
Comment actions Permalink

The problem is already fixed (see http://youtrack.jetbrains.net/issue/IDEA-69684). The fix will appear in the next IDEA 10.5.1 EAP build.

--
Nikolay Chashnikov
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

0

Please sign in to leave a comment.