Can't open projects created pre 3378

I can't even import existing modules created pre 3378 into a new project.

--
"A man's ethical behavior should be based effectually on sympathy,
education, and social ties and needs; no religious basis is necessary. Man
would indeed be in a poor way if he had to be restrained by fear of
punishment and hope of reward after death."
[Albert Einstein, "Religion and Science", New York Times Magazine, 9
November 1930]


9 comments
Comment actions Permalink

I just opened it up myself. Does it give you an error or something?

0
Comment actions Permalink

Just found the problem. Can't use jdk 1.4 with this build. The problem with
that is Weblogic integration still doesn't work well with 1.5.

"Robert S. Sfeir" <robert@NOSPAMCodepuccino.dom> wrote in message
news:robert-550D2C.12481521062005@mail.intellij.net...
>I just opened it up myself. Does it give you an error or something?


0
Comment actions Permalink

I'm curious about this. We're currently using jdk 1.4 with weblogic. However,
I don't start/stop/debug from IDEA right now, I just do a Make Project to
deploy it to my local weblogic. Will this still work in 3378? If not, I'll
have to wait.

Thanks.

Tobin


0
Comment actions Permalink

In article <d99gg3$6k2$1@is.intellij.net>, "Brad" <brad@somewhere.com>
wrote:

Just found the problem. Can't use jdk 1.4 with this build. The problem with
that is Weblogic integration still doesn't work well with 1.5.

"Robert S. Sfeir" <robert@NOSPAMCodepuccino.dom> wrote in message
news:robert-550D2C.12481521062005@mail.intellij.net...
>I just opened it up myself. Does it give you an error or something?


I;m in 1.4, on OSX, I wonder if you have a plugin installed which has
been compiled for JDK 5, that happened to me with the junit plugin.

0
Comment actions Permalink

Brad wrote:

Just found the problem. Can't use jdk 1.4 with this build. The problem with
that is Weblogic integration still doesn't work well with 1.5.

"Robert S. Sfeir" <robert@NOSPAMCodepuccino.dom> wrote in message
news:robert-550D2C.12481521062005@mail.intellij.net...

>>I just opened it up myself. Does it give you an error or something?


The only 1.4/1.5 related problem that I have had with the Weblogic integration was
http://www.jetbrains.net/jira/browse/IDEA-1651
For which Maxim had a workaround:
add the following line to idea.properties: 'jmx.serial.form=1.0'

0
Comment actions Permalink

No, I tried removing all "non-IDEA" plugins. Actually, I have them installed
again and running on 1.5.

"Robert S. Sfeir" <robert@NOSPAMCodepuccino.dom> wrote in message
news:robert-6E89A1.13163121062005@mail.intellij.net...

In article <d99gg3$6k2$1@is.intellij.net>, "Brad" <brad@somewhere.com>
wrote:

>
>> Just found the problem. Can't use jdk 1.4 with this build. The problem
>> with
>> that is Weblogic integration still doesn't work well with 1.5.
>>
>> "Robert S. Sfeir" <robert@NOSPAMCodepuccino.dom> wrote in message
>> news:robert-550D2C.12481521062005@mail.intellij.net...
>> >I just opened it up myself. Does it give you an error or something?
>

I;m in 1.4, on OSX, I wonder if you have a plugin installed which has
been compiled for JDK 5, that happened to me with the junit plugin.



0
Comment actions Permalink

I tried adding that line but I still get tons of errors when trying to
run/debug using IDEA. I get the following error whenever I try to run/debug
and it doesn't matter if I have the run/debug set to deploy a ear/war or
not.
<> <> <> <> ]]>
java.rmi.UnmarshalException: error unmarshalling arguments; nested exception
is:
java.io.StreamCorruptedException
at
weblogic.rjvm.BasicOutboundRequest.sendReceive(BasicOutboundRequest.java:108)
at weblogic.rmi.internal.BasicRemoteRef.invoke(BasicRemoteRef.java:137)
at
weblogic.management.internal.RemoteMBeanServerImpl_814_WLStub.getServerName(Unknown
Source)
at
com.intellij.j2ee.wrappers.RemoteMBeanServerWrapper.getServerName(RemoteMBeanServerWrapper.java:27)
at
com.intellij.j2ee.weblogic.runDebug.weblogicServerInstances.WeblogicAbstractInstance.refreshStateImpl(WeblogicAbstractInstance.java:214)
at
com.intellij.j2ee.weblogic.runDebug.weblogicServerInstances.ServerPollThread$4.run(ServerPollThread.java:307)
at
weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:321)
at
weblogic.security.service.SecurityManager.runAs(SecurityManager.java:121)
at weblogic.security.Security.runAs(Security.java:41)
at com.intellij.j2ee.wrappers.WeblogicLogin.runAs(WeblogicLogin.java:110)
at
com.intellij.j2ee.weblogic.runDebug.weblogicServerInstances.ServerPollThread.refreshState(ServerPollThread.java:304)
at
com.intellij.j2ee.weblogic.runDebug.weblogicServerInstances.ServerPollThread$1.run(ServerPollThread.java:91)
at
com.intellij.j2ee.weblogic.runDebug.weblogicServerInstances.ServerPollThread.runRequest(ServerPollThread.java:278)
at
com.intellij.j2ee.weblogic.runDebug.weblogicServerInstances.ServerPollThread.run(ServerPollThread.java:244)
Caused by: java.io.StreamCorruptedException
at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1301)
at java.io.ObjectInputStream.readObject(ObjectInputStream.java:324)
at
weblogic.common.internal.ChunkedObjectInputStream.readObject(ChunkedObjectInputStream.java:120)
at
weblogic.rjvm.MsgAbbrevInputStream.readObject(MsgAbbrevInputStream.java:120)
at
weblogic.management.internal.RemoteMBeanServerImpl_WLSkel.invoke(Unknown
Source)
at weblogic.rmi.internal.BasicServerRef.invoke(BasicServerRef.java:477)
at weblogic.rmi.internal.BasicServerRef$1.run(BasicServerRef.java:420)
at
weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:363)
at
weblogic.security.service.SecurityManager.runAs(SecurityManager.java:147)
at
weblogic.rmi.internal.BasicServerRef.handleRequest(BasicServerRef.java:415)
at
weblogic.rmi.internal.BasicExecuteRequest.execute(BasicExecuteRequest.java:30)
at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:219)
at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:178)
-


nested within: -


weblogic.rmi.extensions.RemoteRuntimeException: Unexpected Exception - with
nested exception:
[java.rmi.UnmarshalException: error unmarshalling arguments; nested
exception is:
java.io.StreamCorruptedException]
at
weblogic.management.internal.RemoteMBeanServerImpl_814_WLStub.getServerName(Unknown
Source)
at
com.intellij.j2ee.wrappers.RemoteMBeanServerWrapper.getServerName(RemoteMBeanServerWrapper.java:27)
at
com.intellij.j2ee.weblogic.runDebug.weblogicServerInstances.WeblogicAbstractInstance.refreshStateImpl(WeblogicAbstractInstance.java:214)
at
com.intellij.j2ee.weblogic.runDebug.weblogicServerInstances.ServerPollThread$4.run(ServerPollThread.java:307)
at
weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:321)
at
weblogic.security.service.SecurityManager.runAs(SecurityManager.java:121)
at weblogic.security.Security.runAs(Security.java:41)
at com.intellij.j2ee.wrappers.WeblogicLogin.runAs(WeblogicLogin.java:110)
at
com.intellij.j2ee.weblogic.runDebug.weblogicServerInstances.ServerPollThread.refreshState(ServerPollThread.java:304)
at
com.intellij.j2ee.weblogic.runDebug.weblogicServerInstances.ServerPollThread$1.run(ServerPollThread.java:91)
at
com.intellij.j2ee.weblogic.runDebug.weblogicServerInstances.ServerPollThread.runRequest(ServerPollThread.java:278)
at
com.intellij.j2ee.weblogic.runDebug.weblogicServerInstances.ServerPollThread.run(ServerPollThread.java:244)
<> <> <> <> ]]>
java.rmi.UnmarshalException: error unmarshalling arguments; nested exception
is:
java.io.StreamCorruptedException
at
weblogic.rjvm.BasicOutboundRequest.sendReceive(BasicOutboundRequest.java:108)
at weblogic.rmi.internal.BasicRemoteRef.invoke(BasicRemoteRef.java:137)
at
weblogic.management.internal.RemoteMBeanServerImpl_814_WLStub.addNotificationListener(Unknown
Source)
at
com.intellij.j2ee.wrappers.RemoteMBeanServerWrapper.addNotificationListener(RemoteMBeanServerWrapper.java:56)
at
com.intellij.j2ee.weblogic.runDebug.weblogicServerInstances.ServerPollThread.registerMBeansListener(ServerPollThread.java:125)
at
com.intellij.j2ee.weblogic.runDebug.weblogicServerInstances.ServerPollThread.access$500(ServerPollThread.java:31)
at
com.intellij.j2ee.weblogic.runDebug.weblogicServerInstances.ServerPollThread$1.run(ServerPollThread.java:93)
at
com.intellij.j2ee.weblogic.runDebug.weblogicServerInstances.ServerPollThread.runRequest(ServerPollThread.java:278)
at
com.intellij.j2ee.weblogic.runDebug.weblogicServerInstances.ServerPollThread.run(ServerPollThread.java:244)
Caused by: java.io.StreamCorruptedException
at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1301)
at java.io.ObjectInputStream.readObject(ObjectInputStream.java:324)
at
weblogic.common.internal.ChunkedObjectInputStream.readObject(ChunkedObjectInputStream.java:120)
at
weblogic.rjvm.MsgAbbrevInputStream.readObject(MsgAbbrevInputStream.java:120)
at
weblogic.management.internal.RemoteMBeanServerImpl_WLSkel.invoke(Unknown
Source)
at weblogic.rmi.internal.BasicServerRef.invoke(BasicServerRef.java:477)
at weblogic.rmi.internal.BasicServerRef$1.run(BasicServerRef.java:420)
at
weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:363)
at
weblogic.security.service.SecurityManager.runAs(SecurityManager.java:147)
at
weblogic.rmi.internal.BasicServerRef.handleRequest(BasicServerRef.java:415)
at
weblogic.rmi.internal.BasicExecuteRequest.execute(BasicExecuteRequest.java:30)
at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:219)
at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:178)
-


nested within: -


weblogic.rmi.extensions.RemoteRuntimeException: Unexpected Exception - with
nested exception:
[java.rmi.UnmarshalException: error unmarshalling arguments; nested
exception is:
java.io.StreamCorruptedException]
at
weblogic.management.internal.RemoteMBeanServerImpl_814_WLStub.addNotificationListener(Unknown
Source)
at
com.intellij.j2ee.wrappers.RemoteMBeanServerWrapper.addNotificationListener(RemoteMBeanServerWrapper.java:56)
at
com.intellij.j2ee.weblogic.runDebug.weblogicServerInstances.ServerPollThread.registerMBeansListener(ServerPollThread.java:125)
at
com.intellij.j2ee.weblogic.runDebug.weblogicServerInstances.ServerPollThread.access$500(ServerPollThread.java:31)
at
com.intellij.j2ee.weblogic.runDebug.weblogicServerInstances.ServerPollThread$1.run(ServerPollThread.java:93)
at
com.intellij.j2ee.weblogic.runDebug.weblogicServerInstances.ServerPollThread.runRequest(ServerPollThread.java:278)
at
com.intellij.j2ee.weblogic.runDebug.weblogicServerInstances.ServerPollThread.run(ServerPollThread.java:244)
<> <> <> <> ]]>
java.rmi.UnmarshalException: error unmarshalling arguments; nested exception
is:
java.io.StreamCorruptedException
at
weblogic.rjvm.BasicOutboundRequest.sendReceive(BasicOutboundRequest.java:108)
at weblogic.rmi.internal.BasicRemoteRef.invoke(BasicRemoteRef.java:137)
at
weblogic.management.internal.AdminMBeanHomeImpl_814_WLStub.getMBean(Unknown
Source)
at
com.intellij.j2ee.wrappers.WebLogicMBeanWrapper.getMBean(WebLogicMBeanWrapper.java:96)
at
com.intellij.j2ee.weblogic.runDebug.weblogicServerInstances.WeblogicAbstractInstance.getDeploymentStatus(WeblogicAbstractInstance.java:432)
at
com.intellij.j2ee.weblogic.runDebug.weblogicServerInstances.WeblogicAbstractInstance.access$400(WeblogicAbstractInstance.java:79)
at
com.intellij.j2ee.weblogic.runDebug.weblogicServerInstances.WeblogicAbstractInstance$2.run(WeblogicAbstractInstance.java:406)
at
com.intellij.j2ee.weblogic.runDebug.weblogicServerInstances.ServerPollThread$3.run(ServerPollThread.java:272)
at
weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:363)
at
weblogic.security.service.SecurityManager.runAs(SecurityManager.java:147)
at weblogic.security.Security.runAs(Security.java:61)
at com.intellij.j2ee.wrappers.WeblogicLogin.runAs(WeblogicLogin.java:106)
at
com.intellij.j2ee.weblogic.runDebug.weblogicServerInstances.ServerPollThread.runRequest(ServerPollThread.java:270)
at
com.intellij.j2ee.weblogic.runDebug.weblogicServerInstances.ServerPollThread.run(ServerPollThread.java:244)
Caused by: java.io.StreamCorruptedException
at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1301)
at java.io.ObjectInputStream.readObject(ObjectInputStream.java:324)
at
weblogic.common.internal.ChunkedObjectInputStream.readObject(ChunkedObjectInputStream.java:120)
at
weblogic.rjvm.MsgAbbrevInputStream.readObject(MsgAbbrevInputStream.java:120)
at weblogic.management.internal.AdminMBeanHomeImpl_WLSkel.invoke(Unknown
Source)
at weblogic.rmi.internal.BasicServerRef.invoke(BasicServerRef.java:477)
at weblogic.rmi.internal.BasicServerRef$1.run(BasicServerRef.java:420)
at
weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:363)
at
weblogic.security.service.SecurityManager.runAs(SecurityManager.java:147)
at
weblogic.rmi.internal.BasicServerRef.handleRequest(BasicServerRef.java:415)
at
weblogic.rmi.internal.BasicExecuteRequest.execute(BasicExecuteRequest.java:30)
at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:219)
at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:178)
-


nested within: -


weblogic.rmi.extensions.RemoteRuntimeException: Unexpected Exception - with
nested exception:
[java.rmi.UnmarshalException: error unmarshalling arguments; nested
exception is:
java.io.StreamCorruptedException]
at
weblogic.management.internal.AdminMBeanHomeImpl_814_WLStub.getMBean(Unknown
Source)
at
com.intellij.j2ee.wrappers.WebLogicMBeanWrapper.getMBean(WebLogicMBeanWrapper.java:96)
at
com.intellij.j2ee.weblogic.runDebug.weblogicServerInstances.WeblogicAbstractInstance.getDeploymentStatus(WeblogicAbstractInstance.java:432)
at
com.intellij.j2ee.weblogic.runDebug.weblogicServerInstances.WeblogicAbstractInstance.access$400(WeblogicAbstractInstance.java:79)
at
com.intellij.j2ee.weblogic.runDebug.weblogicServerInstances.WeblogicAbstractInstance$2.run(WeblogicAbstractInstance.java:406)
at
com.intellij.j2ee.weblogic.runDebug.weblogicServerInstances.ServerPollThread$3.run(ServerPollThread.java:272)
at
weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:363)
at
weblogic.security.service.SecurityManager.runAs(SecurityManager.java:147)
at weblogic.security.Security.runAs(Security.java:61)
at com.intellij.j2ee.wrappers.WeblogicLogin.runAs(WeblogicLogin.java:106)
at
com.intellij.j2ee.weblogic.runDebug.weblogicServerInstances.ServerPollThread.runRequest(ServerPollThread.java:270)
at
com.intellij.j2ee.weblogic.runDebug.weblogicServerInstances.ServerPollThread.run(ServerPollThread.java:244)


"Tim Haley" <ymaraner@yahoo.com> wrote in message
news:d99jfo$kn8$1@is.intellij.net...

Brad wrote:

>> Just found the problem. Can't use jdk 1.4 with this build. The problem
>> with that is Weblogic integration still doesn't work well with 1.5.
>>
>> "Robert S. Sfeir" <robert@NOSPAMCodepuccino.dom> wrote in message
>> news:robert-550D2C.12481521062005@mail.intellij.net...
>>
>>>I just opened it up myself. Does it give you an error or something?
>>
>>
>>

The only 1.4/1.5 related problem that I have had with the Weblogic
integration was http://www.jetbrains.net/jira/browse/IDEA-1651
For which Maxim had a workaround:
add the following line to idea.properties: 'jmx.serial.form=1.0'



0
Comment actions Permalink

Brad wrote:

I tried adding that line but I still get tons of errors when trying to
run/debug using IDEA. I get the following error whenever I try to run/debug
and it doesn't matter if I have the run/debug set to deploy a ear/war or
not.


I'm getting the same problem on my PC at work, but I've had it working on my home PC
already, though setting the system property caused JBoss not to work any more then...

I've just updated to WebLogic 8.1 SP4 but that didn't help anything. I've got no more
ideas how to hunt down this error :( Any help is appreciated.

Sascha

0
Comment actions Permalink

Forgot to mention that if I DO try to deploy an ear, I get that error and
the Deployment status always says "Disconnected" even though it seems to
have deployed okay.. But I get that error when I start IDEA regardless if I
deploy something or not. Of course, just switching to jdk 1.4 cured all
these before this build but now I can't do that:(

"Sascha Weinreuter" <sascha.weinreuter@NOSPAM-cit.de> wrote in message
news:d99lqs$uol$1@is.intellij.net...

Brad wrote:

>> I tried adding that line but I still get tons of errors when trying to
>> run/debug using IDEA. I get the following error whenever I try to
>> run/debug
>> and it doesn't matter if I have the run/debug set to deploy a ear/war or
>> not.
>

I'm getting the same problem on my PC at work, but I've had it working on
my home PC
already, though setting the system property caused JBoss not to work any
more then...

>

I've just updated to WebLogic 8.1 SP4 but that didn't help anything. I've
got no more
ideas how to hunt down this error :( Any help is appreciated.

>

Sascha



0

Please sign in to leave a comment.