I miss the Application Servers settings ?

Hi

I am developing a Web Application at the moment in IntelliJ 10.
The problem is I cannot find the tab APPLICATION SERVERS in settings.
Neither do I find thje default Debug/Run configurations for Glassfish, Tomcat ...

I only have Debug/Run configurations for : jUnit, Groovy , Applet, Application , Android, Maven, Plugin, Remote and XSLT.
My goal is to run my project on a Glassfish server.

Why do I have this problem ? And how can I solve this.
I work on a Windows Xp workstation at my work (I cannot upgrade this), with IntelliJ 10 (Community edition).
I already tried to delete and uninstall previous version with their settings, catch, etc ... (including .IntelliJ folders) to do a clean install afterwards.

Can someone help me, It would be much more sufficient to Run/Debug from IntelliJ instead of deplying my app everytime on my local glassfish server.

Thanks, Ian

3 comments
Comment actions Permalink

Community Edition has no support web development - you have to get the Ultimate for that.

IntelliJ IDEA Editions Comparison: http://www.jetbrains.com/idea/features/editions_comparison_matrix.html?IC

0
Comment actions Permalink

That is weir... I have a communicty version on my macbook air.. And it has the support ?
So weird :s

0
Comment actions Permalink

if you use maven, you can use maven actions instead of run configurations for web app. And i believe remote debug should be avilaible in the community edition. Probably it will be sufficient for you.

0

Please sign in to leave a comment.