git master gant build problem

I have been experiencing build failures (or rather the build not even starting) for a couple of days on git "origin/master".

     [java] Buildfile: G:\proj\jetbrains\community\build\gant.xml
     [java] 
     [java] doGant:
     [java] home is not defined. Defaulting to G:\proj\jetbrains\community
     [java] out is not defined. Defaulting to G:\proj\jetbrains\community/out
     [java] 
     [java] BUILD FAILED
     [java] G:\proj\jetbrains\community\build\gant.xml:17: groovy.lang.MissingPropertyException: No such property: community-resources for class: dist


I experience this on both win32 and osx. I wondered if others are having a similar outcome, and if not, are there reasonable steps I could try without resorting to a fresh git clone?

Git states that my working directory is clean, for what that's worth.

  Thanks kindly,
  -- /v\atthew

4 comments
Comment actions Permalink

Hello Matthew,

This was actually caused by an error in the Community Edition build scripts.
I've pushed the fix for the error, so it should build correctly now.

I have been experiencing build failures (or rather the build not even
starting) for a couple of days on git "origin/master".

Buildfile: G:\proj\jetbrains\community\build\gant.xml

doGant:
home is not defined. Defaulting to
G:\proj\jetbrains\community
out is not defined. Defaulting to
G:\proj\jetbrains\community/out

BUILD FAILED
G:\proj\jetbrains\community\build\gant.xml:17:
groovy.lang.MissingPropertyException: No such property:
community-resources for class: dist
I experience this on both win32 and osx. I wondered if others are
having a similar outcome, and if not, are there reasonable steps I
could try without resorting to a fresh git clone?

Git states that my working directory is clean, for what that's worth.


--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Apologies for the delay. Your commit did fix the original problem, however, it exposed a subsequent build failure. I wanted to try it out on my Mac at home before replying, to avoid crying wolf.

     [java] Total compilation time: 7 minutes 2.592 seconds, 0 java files in 93 chunks compiled
     [java]  CustomTasksBuilder: 0 minutes 0.027 seconds
     [java]  GroovyStubGenerator: 0 minutes 1.852 seconds
     [java]  JavacBuilder: 6 minutes 24.322 seconds
     [java]  GroovycBuilder: 0 minutes 2.166 seconds
     [java]  ResourceCopier: 0 minutes 6.861 seconds
     [java]  JetBrainsInstrumentations: 0 minutes 24.308 seconds
     [java] 
     [java] BUILD FAILED
     [java] /Users/mdaniel/Projects/community/build/gant.xml:17: No such property: component.version.major for class: utils
     [java] 
     [java] Total time: 7 minutes 6 seconds
     [java] ------ compile


I hope this comes across in the genuinely inquisitive manner in which I mean it, but is there no build-bot for the Community edition?

  -- /v\atthew

0
Comment actions Permalink

Hello Matthew,

Indeed, my fix was incomplete. I'll fix this more correctly tomorrow.

There is a TeamCity build configuration for the Community Edition distribution,
but unfortunately the developers sometimes don't pay as much attention to
it as to the Ultimate build configurations.

Apologies for the delay. Your commit did fix the original problem,
however, it exposed a subsequent build failure. I wanted to try it out
on my Mac at home before replying, to avoid crying wolf.

Total compilation time: 7 minutes 2.592 seconds, 0 java
files in 93 chunks compiled
  CustomTasksBuilder: 0 minutes 0.027 seconds
  GroovyStubGenerator: 0 minutes 1.852 seconds
  JavacBuilder: 6 minutes 24.322 seconds
  GroovycBuilder: 0 minutes 2.166 seconds
  ResourceCopier: 0 minutes 6.861 seconds
  JetBrainsInstrumentations: 0 minutes 24.308 seconds

BUILD FAILED
/Users/mdaniel/Projects/community/build/gant.xml:17: No
such property: component.version.major for class: utils

Total time: 7 minutes 6 seconds
------ compile
I hope this comes across in the genuinely inquisitive manner in which
I mean it, but is there no build-bot for the Community edition?

-- /v\atthew

---
Original message URL:
http://devnet.jetbrains.net/message/5302000#5302000


--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Please tell Roman thank you for me; commit e9de2ee34f4b fixed it right up.

     [java] ##teamcity[publishArtifacts '/out/artifacts/ideaIC-108.SNAPSHOT.win.zip']
     [java] ------ default
     [java] 
     [java] BUILD SUCCESSFUL
     [java] Total time: 11 minutes 16 seconds


  -- /v\atthew

0

Please sign in to leave a comment.