How do I force a clean artifact build in Intellij 10 ?

How do I force my artifact to be built cleanly from Intellij in INtellij 10.0.2?   When the artifact is built it only replaces files that don't exist or classes that changed.  However, I would like to do a full clean compile and build at times as I tinker with my artifact  in the development process (which is fine).

4 comments
Comment actions Permalink

Project Settings/Compiler - make sure "Clear output directory on rebuild" is checked. Then run Build/Rebuild Project to clean and rebuild everything.

Grant

0
Comment actions Permalink

'Clear output directory on rebuild' option doesn't affect artifacts. Unfortunately some people uses project root directory as artifact output and we
don't want to delete all project files in such cases.

So now there is no way to automatically clear artifacts outputs. Feel free to create an issue for that in our tracker
(http://youtrack.jetbrains.net/issues/IDEA)

Project Settings/Compiler - make sure "Clear output directory on rebuild" is checked. Then run Build/Rebuild Project to clean and rebuild everything.

>

Grant

>

---
Original message URL: http://devnet.jetbrains.net/message/5286059#5286059



--
Nikolay Chashnikov
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

0
Comment actions Permalink

I have an exact opposite problem:

attempt to update my running app from the Debug tab, it seems to make whole project from scratch, instead of compiling and refreshing changed files only.

I spent a day looking though settings and comparing them to the setting on another machine (Mac) - nothing.

And I am not dreaming - same project reloads just fine on a Mac, and used to reload just fine on Ubuntu (before upgrade)

Any ideas?

Sincerely,

Alexander

Ubuntu 11 (Natty Narwhal, upgraded yesterday), IDEA 10.0.3, UI 103.255)

0

Please sign in to leave a comment.