Intellij Idea 9 slow response on typing.

I'm using IntelliJ Idea 9 on a windows 7 box. I'm facing this strange issue where the response of the editor is very slow. When typing, the characters seem to appear after a delay.. and gets annoying after a point.

Would like to know if someone has faced this earlier.. Or is there any recommended solution..

Thanks.

24 comments
Comment actions Permalink

Thanks @Serge. Will try it out and publish my findings.. Thanks for the quick response.

0
Comment actions Permalink

Hi Serge,
I've got the same problem even with the updated v. 9.0.1.
The idea.exe process utilizes 40-50% and more the CPU even while I am just typing/adding rows/deleting rows in a .java file.
I disabled the 'suspicious' plugins like 'Struts 1.x, Struts 2, SpellChecker, UML Support' which doesn't look like helped.

Any help would be much appreciated.

Cheers,
Dob

P.S. XP Prof; 3 GB Ram;
Here is my idea.exe.vmoptions

-Xms256m
-Xmx512m
-XX:MaxPermSize=256m
-ea

0
Comment actions Permalink

Hi Serge,

Just uploaded file *02.02.2010_15.49.50.zip.

vmoptions:
-Xms512m
-Xmx1024m
-XX:MaxPermSize=256m
-ea
-agentlib:yjpagent



I had opened only one .java files and kept typing.
The file attached shows the CPU utilization.

Please get in touch once this issue is resolved.

Thanks a lot,
Dob

Attachment(s):
CPU load during Mem Profiling.JPG
0
Comment actions Permalink

You've uploaded a memory snapshot. We need a CPU snapshot. Please try again.

0
Comment actions Permalink

File name: *02.02.2010_16.32.01.zip



Attachment(s):
CPU load during Mem Profiling.JPG
0
Comment actions Permalink

Please upload YourKit profiler CPU snapshot to our FTP as described in the FAQ linked above.

---
Original message URL: http://www.jetbrains.net/devnet/message/5255769#5255769

0
Comment actions Permalink

550 IU-93.94_***_02.02.2010_16.32.01.zip: Overwrite permission denied  
IU-93.94_***_02.02.2010_16.32.01.zip - 0 bytes transferred  
PASV  



What was wrong with the first upload?

Uploading the file second time:

*02.02.2010_16.32.01_second_upload.zip

Cheers,
Dob
0
Comment actions Permalink

The CPU snapshot was uploaded OK, our developers will investigate it, thanks.

0
Comment actions Permalink

Hi,

are there any news on this topic? I also am very disappointed about this behaviour, it disturbes heavily my typing flow. I even updated to Maia 9.0.2 EAP (Build 94.273), but that didn't help

I would be very glad if that annoying issue would be fixed!

Regards,
Martin

0
Comment actions Permalink

Hello Martin,

are there any news on this topic? I also am very disappointed about
this behaviour, it disturbes heavily my typing flow. I even updated to
Maia 9.0.2 EAP (Build 94.273), but that didn't help

I would be very glad if that annoying issue would be fixed!


I've said this many times before and will have to say this again: The only
way to make sure that the performance issue you're seeing is fixed is to
file a YouTrack issue with a CPU snapshot attached. Otherwise, there's no
way to find out whether you're seeing "that" annoying issue or some other,
completely unrelated annoying issue.

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

I uploaded my CPU snapshot, filename is IU-94.273_mpr_25.02.2010_12.58.39.zip. I took the CPU snapshot while just typing a bit within a java class.

Is this okay for you?


My idea.vmoptions:
-Xms256m
-Xmx768m
-XX:MaxPermSize=300m
-ea
-server
-Dsun.java2d.pmoffscreen=false
-XX:+UseCompressedOops
-agentlib:yjpagent


My machine:
Linux 2.6.31-19-generic #56-Ubuntu SMP Thu Jan 28 02:39:34 UTC 2010 x86_64 GNU/Linux
4G RAM

0
Comment actions Permalink

It looks like you are using a server JVM, it's known that server JVM has greater compile threshold.
This means it runs more in interpreter mode before generating a machine code.
I'm also using concurrent mark sweep GC. It provides lower latency than default one (at least on my machine).
Try adding the following switches to your JVM configuration:

-XX:+UseConcMarkSweepGC
-XX:CompileThreshold=100  
0
Comment actions Permalink

I tried it, but it has no effect on the CPU load and the editor performance.

0
Comment actions Permalink

Hello Martin,

I uploaded my CPU snapshot, filename is
IU-94.273_mpr_25.02.2010_12.58.39.zip. I took the CPU while just
typing a bit within a java class.

Is this okay for you?


Thanks for the snapshot! It does seem to be the same problem, caused by excessive
tree updates. We're looking into it now.

What toolwindows do you have open when this happens?

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Besides the code editor only the project tool window is opened (scope All).

0
Comment actions Permalink

I've just updated to 94.426 and am seeing this issue (didn't see it before).

JVM Settings:
-Xms128m
-Xmx750m
-XX:MaxPermSize=250m
-ea
-agentlib:yjpagent


I've attached a CPU snapshot as well.



Attachment(s):
IU-94.426_akrieg_01.03.2010_09.56.40.zip
0
Comment actions Permalink

Hi Serge,

I've got the same problem even with the updated v. 9.0.1.

The idea.exe process utilizes 40-50% and more the CPU even while I am just typing/adding rows/deleting rows in a .java file.

I disabled the 'suspicious' plugins like 'Struts 1.x, Struts 2, SpellChecker, UML Support' which doesn't look like helped.



Any help would be much appreciated.



Cheers,

Dob

Yes, I have the same problem. The idea 8 has no problem

P.S. XP Prof; 2 GB Ram;
Here is my idea.exe.vmoptions

-Xms256m
-Xmx678m
-XX:MaxPermSize=250m
-ea

0
Comment actions Permalink

Hello truecolor,

Please capture a CPU snapshot as described in http://www.jetbrains.net/devnet/docs/DOC-1144
and file a YouTrack issue with the snapshot attached.

Hi Serge,
>
> I've got the same problem even with the updated v. 9.0.1.
>
> The idea.exe process utilizes 40-50% and more the CPU even while I am
> just typing/adding rows/deleting rows in a .java file.
>
> I disabled the 'suspicious' plugins like 'Struts 1.x, Struts 2,
> SpellChecker, UML Support' which doesn't look like helped.
>
> Any help would be much appreciated.
>
> Cheers,
>
> Dob

Yes, I have the same problem. The idea 8 has no problem
P.S. XP Prof; 2 GB Ram;
Here is my idea.exe.vmoptions

-Xms256m
> -Xmx678m
> -XX:MaxPermSize=250m
> -ea

---
Original message URL:
http://www.jetbrains.net/devnet/message/5260343#5260343

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

I dono if you have come to a solution but I have the exact samt problem running a Dell Latitude D830 Centrino Duo 2,4 Ghz with

4 GB om ram on a Windows XP.

A collegue of mine was running the IntelliJ 8.x on a MacBook Pro 2,9 Ghz and it really is fast as he....!

(yes its a faster CPU but there must be an issu of running the same code for checking some spelling or something over and over again before releasing it)

The worst thing is that it seems to get heavier after a while I need to have at least 2-3 IntelliJ projects running to be able to handle centralized Lib and changes

in that Lib and then run one or two client projects along with that running on the same centralized lib.

I was just searching for this problem because I was once again in a slow-as-he... period where If I change lets say "<li>hello</li>" to "< li>hello</li>" in a JSP

page and back to "<li>hello</li>" again and doest this really quick the delay right now is about 47 seconds. As you can understand its nearly unusable but I

have no choice I must use IntelliJ for many reasons and I really love the IDEA.

It has even come to the result of this problem that I ordered the latest Latitude E6510 with I7 820 QuadCore CPU 8 GB of ram SSD drive just to be able to

run it more smoothly as we are awaiting a fix.

Please let me know if you need another CPU, Memory profile sent in.

Regards,

Christopher Berg

3W Solutions AB

0
Comment actions Permalink

With 4 or 8 gig of memory I'd recommend using a ramdisk for the Intellij system cache. I finally gave it a try when I upgraded my laptop to 8 gig. What a difference. My maven build time was cut in half from 40 to 19 seconds and IDE reponsiveness returned. Everything is fast. If you have the memory and Intellij is the resource hog try it.

0
Comment actions Permalink

Hi All,

Just installed the latest Patch 9.0.2 and all my problems went away - Cheers!

Best Regards,
Christopher Berg

http://www.3wsolutions.se

0
Comment actions Permalink

uk chucktown wrote:

With 4 or 8 gig of memory I'd recommend using a ramdisk for the Intellij system cache. I finally gave it a try when I upgraded my laptop to 8 gig. What a difference. My maven build time was cut in half from 40 to 19 seconds and IDE reponsiveness returned. Everything is fast. If you have the memory and Intellij is the resource hog try it.

---
Original message URL: http://www.jetbrains.net/devnet/message/5263292#5263292

My system dir is currently over 6G in size, so I don't think I'll be
doing that any time soon... of course there may be all sorts of cruft in
there that needs cleaning out...
N.

0

Please sign in to leave a comment.