In 10.0.3 IdeaVIM doesn't work in dialog boxes

This first appeared to occur in 10.0.3 (I don't recall it happend in 10.0.1 and .2). However, previously in dialog boxes you could use VI keystrokes (like "cw", "x", etc") in dialog boxes with IdeaVIM plugin. In 10.0.3 IdeaVIM no longer works in dialog boxes. Is this by design? Is there a setting somewhere? Or is this a bug?

This is especially annoying in the rename dialog (shift-f6) since that is used quite often and I now have to take my fingers off of home row and go to the arrows to move the cursor.

4 comments
Comment actions Permalink

Hello Michael,

Sorry for the long delay in reply, I had my hands full, this was made intentionally, because of the number of users who got confused by the previous behavior, however I guess we should add an option for this in future plugin version.

Regards,
Oleg

0
Comment actions Permalink

If this could be be made optional so I can have it back that would be awesome. It is really a step backwards not to have it.

It would also be nice if the IdeaVIM plugin was active that the ESC key doesn't close dialogs. That is the only draw back to have IdeaVIM on the dialogs, sometimes I accidentally close them with ESC trying to leave edit mode. Usually I remember not to hit ESC but habits are hard to break.

I found IdeaVIM in dialogs to be a very nice thing.

Do you need me to open a youtrack issue?

1
Comment actions Permalink

Yes please, this would be great, and you'll get notified instantly once it is done.

Regards,
Oleg

0
Comment actions Permalink

I have opened a youtrack issue for this:  http://youtrack.jetbrains.net/issue/VIM-99

0

Please sign in to leave a comment.