can I configure idea10 ultimate to echo every keybinding in the status bar before executing it?

I'm running idea10 over Ubuntu 10.10 (lots of tens here). Idea10 says I have a keybinding for 'Comment with Line Comment' at Ctrl-/. When I type Ctrl-/, it doesn't do anything. My guess is that gnome window manager is intercepting the binding. Can I configure idea10 to echo each keybind/bound command before executing it? THanks.

6 comments
Comment actions Permalink

Pilot error. I was typing Ctrl-\ not Ctrl-/.

Note that the related command 'Comment With Block Comment' in Python/Pycharm doesn't do anything. Python doesn't appear to have a block comment delimiter. This is incredibly confusing at first. I still think there should be an 'echo mode' in the status line. Or some kind of feedback mechanism.

0
Comment actions Permalink

There is no "echo mode" in IntelliJ IDEA, and frankly speaking I don't quite understand how you expect it to work. Every keyboard shortcut can be assigned to multiple actions, and only the action which is enabled in the given context is executed. The "Comment with block comment" action is not enabled in Python files, precisely because the Python language doesn't support block comments.

0
Comment actions Permalink

So code that dispatches the action couldn't write a confirmation in the status bar?

Let me give this question some context. I use idea10 on ubuntu 10.10 (and 11.4 when it arrives). A keychord will go through the gnome window manager to idea10. It can be intercepted by gnome, in which case it does a gnome action (if I'm lucky, since I can see it). It can be intercepted by idea10 and does the idea10 action. Again, if I'm lucky the action has an obvious effect. In some cases, I might type a keychord and nothing happens. Is that because gnome evaluated it? Idea evaluated it, but it doesn't do anything like [Comment With Block Comment] in a python file? Or because I fumblefingered the chord, like I did above with [Comment With Line Comment]? I currently don't know a good, fast way to diagnosis this and some idea10 feedback would be helpful while I memorize the right keybindings.

I suggested an approach, but your knowledge of idea10 might lead you to a different approach. Thanks.

0
Comment actions Permalink

Back when I was using Ubuntu as a better than Windows but not quite good as a Mac solution it was quite annoying that GNOME intercepted almost all the keyboard shortcuts. I had to end up disabling all GNOME keyboard shortcuts. You are right that GNOME is intercepting many of the shortcuts that IntelliJ uses. If GNOME handles the shortcut it does not re-dispatch it out for other apps to handle (IMHO it should redispatch to the app that has focus). You choices are to disable all the GNOME shortcuts, or painstakingly go through and change al shortcuts that have a conflict (either change them in GNOME or IntelliJ).

However, I see what you are saying. If IntelliJ would put some sort of inidicator on the screen (like in the status bar) that it was handling a keyboard shortcut it would make it easy to tell if IntelliJ was receiving the keyboard shortcut or was being handled by the OS or windowing system. Mac's aren't immune to this (like ctrl-space opens spotlight by default, had to remap that in System Preferences) but the Mac keymap helps tremendously.

If you open an issue I will give it my vote. This would help troubleshoot keymap conflicts.

0
Comment actions Permalink

Also, I notice that IntelliJ 10 has a "Default for GNOME" keymap. You may want to give that a try. It probably tries to avoid as many conflicts as possible. There will be a learning curve associated with it if you already have your current shortcuts memorized, but would probably be worth it in the long run.

0

Please sign in to leave a comment.