Editing POM.XML in IntelliJ - No Autocomplete for maven-dependency-plugin

hen I am editing a pom.xml file and I am using the maven-dependency-plugin, I get no "auto complete" for completing the xml.   For example if i type <goal> then hit control-space it only says "No Suggestions"  The weird part is that I am using other maven plug-ins in the same pom.xml and I get full auto complete support.

How does Intellij find the xsd for the specific plugins?

Any ideas why I am having problems with only one plug-in?

Thanks!

4 comments
Comment actions Permalink

I cannot reproduce the problem, please post the <plugin> section snippet.

Thanks,
Anton Makeev

0
Comment actions Permalink

Thanks!.... Posting image to show highlighting...

Also no autocomplete for anything under <configuration>

        <plugins>
            <plugin>
                <groupId>org.apache.maven.plugins</groupId>
                <artifactId>maven-dependency-plugin</artifactId>
                <version>2.2</version>
                <executions>
                    <execution>
                        <phase>compile</phase>
                        <goals>
                            <goal>copy</goal>
                        </goals>
                    </execution>
                </executions>
                <configuration>
                    <artifactItems>
                        <artifactItem>
                            <groupId>gov.va.vaonce</groupId>
                            <artifactId>wsdl</artifactId>
                            <version>1.1.0</version>
                            <type>wsdl</type>
                            <destFileName>vaonce-1.1.wsdl</destFileName>
                        </artifactItem>
                    </artifactItems>
                    <outputDirectory>${basedir}/src/wsdl</outputDirectory>
                </configuration>
            </plugin>



Attachment(s):
Capture.PNG
Capture2.PNG
0
Comment actions Permalink

John, please check one thing for me: middle-click on the plugin declaration (<artifactId>maven-{click here}dependency-plugin</artifactId>) to open its pom.xml in the editor. After that please made some changes in the editor to force rehighlighting.
Will the problem remain? And if you restart IDEA?

Thanks

0
Comment actions Permalink

Restart of Intellij took care of it  (I thought have thought of that before :)

Crazy question....how do you middle-click on windows?  I could only right-clilck and reimport.  

Thanks again!

0

Please sign in to leave a comment.